[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Red/green blinking LED on QNAP TS220

On 12/6/18 11:58 AM, Paul van der Vlis wrote:
Hi Moritz and others,

Thanks for you help. I could fix the problem, but I have some
corrections on the info:

Op 06-12-18 om 16:16 schreef Moritz Horstmann:
Hi Paul,

This might be a problem with qcontrol in stretch, your fan is also
probably not controlled.
See this blogpost for a proposed fix:

This is about btrfs, I am using ext4.
And about 1GB RAM, this device has 501 MB RAM.

Solution (fixes led, buzzer and fan): #qcontrol needs stretch backports:
apt-get -t stretch-backports install qcontrol, so add to

deb http://ftp.ch.debian.org/debian/ stretch-backports main

and /lib/systemd/system/qcontrold.services is broken: replaces lines

typo. It's  /lib/systemd/system/qcontrold.service


ConditionPathExists=/dev/input/by-path/platform-gpio_keys-event (kernel
4.9) or platform-gpio-keys-event (kernel 3.16)

I did this.

and afterwards run
dpkg –configure qcontrol

Gave problems:
root@qnap:/home/paul# dpkg –configure qcontrol
dpkg: error: need an action option
root@qnap:/home/paul# dpkg-reconfigure qcontrol
/usr/sbin/dpkg-reconfigure: qcontrol is broken or not fully installed

I did again "apt-get -t stretch-backports install qcontrol". This gave a
W: APT had planned for dpkg to do more than it reported back (0 vs 4).
    Affected packages: qcontrol:armel

After that I could start qcontrold with "service qcontrold start" and
the LED does not blink anymore. The fan seems to be controlled (says
"service qcontrold status".

Flashing the kernel and initrmafs takes some time...

Thanks for the help!

With regards,



Am 2018-12-06 15:09, schrieb Paul van der Vlis:

I have a QNAP TS220 here, used for backups. It runs many years 24/7,
every time upgraded. Now Debian9.

But I had a problem, I could not access it anymore. A hard reboot did
not help, a reboot of my switch did help. So I can access it now again
using SSH. I am using mdadm, and the raid seems to be OK.

My "problem" is that I see a red/green flashing LED. I have not seen
that before, so far I know.  Can somebody tell me what it means? Or how
I can find that?

With regards,
Paul van der Vlis

Thanks for the solution to a long annoyance. :-D It never occurred to me that there might be a fix in Backports.

I was a bit confused by the proposed solution, but I eventually got to the same result. It works.

Here's more or less what I actually did.

- The install from Backports will indeed leave the qcontrol package in a broken state, most likely caused by the failure to start the service. It is not recommended to directly edit or replace the systemd units in the /lib/systemd tree. It's best to use the /etc/systemd mechanism. Furthermore, because you cannot just override the Requires and After settings, the unit file must be replaced in its entirety. (I think.)


systemctl edit --full qcontrold.service

Under the [Unit] section, comment out the Requires and After settings. And add:


Save the file and let systemd know a service has changed:

systemctl daemon-reload

Then try to enable the service.

systemctl enable qcontrold.service


systemctl status qcontrold.service

If there's a problem, iterate.

Now that the service is working, complete the installation of the package with:

apt install

The installation should now complete, with the warning mentioned in the original post. The qcontrold service should have been started. In my case, I had to restart it, probably because of all the trials and errors.

Anyway that's more or less what I tried. I can't verify these steps as written because I only have (had) one box with the condition. So it's YMMV.

Thanks again.


The trouble with common sense it that it is so uncommon.

Reply to: