[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on Seagate Personal Cloud and Seagate NAS

Hi Martin,

Thanks for the feedback.
It would be great if Simon could test the installation with the most
recent version of the installer. I can't boot the installer.

Regarding clunc issues, I found out the netcat behavior has changed for
some reason. I've tried with current netcat version, and clunc fails,
because the call to netcat fails.

So, with recent versions of netcat-openbsd, clunc fails with this error:

nc -u -p 6666 6666
usage: nc [-46CDdFhklNnrStUuvZz] [-I length] [-i interval] [-M ttl]
      [-m minttl] [-O length] [-P proxy_username] [-p source_port]
      [-q seconds] [-s source] [-T keyword] [-V rtable] [-W recvlimit]
[-w timeout]
      [-X proxy_protocol] [-x proxy_address[:port]]       [destination]

The work around is to use the package netcat-traditional and edit clunc
to replace the call to nc with nc.traditional. The call will be:
nc.traditional -u -p 6666 6666

Both netcat-openbsd and netcat-traditional can coexist.



Às 12:09 de 07/05/2018, Martin Michlmayr escreveu:
> * Jorge Gustavo Rocha <jgr@geomaster.pt> [2018-05-06 00:56]:
>> I've followed the available instructions on:
>> https://wiki.debian.org/InstallingDebianOn/Seagate/PersonalCloud
>> 1) The tftp server is running and I'm able to get the files
>> 2) I can access the U-Boot console with clunc and run the commands:
> ...
>> But after the message:
>> Starting kernel ...
>> nothing more happens. I can't connect with ssh. I can't ping to the
> So this happens when you try to boot the installer?
> I'm not aware of any problems with that but I haven't tested it in a
> while (and don't have hardware right now).  Simon, can you test if
> https://wiki.debian.org/InstallingDebianOn/Seagate/PersonalCloud
> works for you on the Personal Cloud?
>> How can I check what is going wrong? Is there any log file where to look
>> for errors?
> Not at this point, I don't think so.
>> Can I run netconsole or something similar to see what is going on?
> That's not built into the kernel iirc.
> I assume you can still connect to u-boot with clunc, right?
> We have received some reports from users that they could no longer
> connect to u-boot with clunc after installing Debian.  Simon Guinot
> (the Seagate NAS expert) investigated this issue quite a bit and
> couldn't find the cause.  I will add a warning about this to the wiki.
> Your issue is different but I wanted to point this out here.

Geomaster, Lda
Avenida Barros e Soares, 423
4715-214 Braga
NIF 510906109
Tel 253 680 223
Tm  910 333 888
Email jgr@geomaster.pt
Site geomaster.pt
GPS 41.53322,-8.41929

Reply to: