[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NextThing C.H.I.P. v1.0 - Debian Stretch Installer from USB

On 2017-06-21, Pablo Rath wrote:
> As this is a rather long message I start with a brief summary:
> I try to install Debian Stretch (Stable, armhf) with the Debian Installer on a
> NextThing Chip v1.0 Allwinner board. After some initial problems I
> managed to complete installation but as far as I understand the kernel
> doesn't load the rootfs. I believe I am missing the correct U-Boot
> commands. I use a self-compiled mainline U-Boot via sunxi-fel to
> circumvent the U-Boot version on NAND provided by the manufacturer.
> I am glad for any help to make the board boot Debian Stretch.

I tried this a while back, but haven't tried recently as using sunxi-fel
is a bit of a cumbersome boot process... and mainline u-boot didn't yet
support being loaded from NAND on the CHIP. Haven't tried since u-boot
2016.11+dfsg1-3 in the u-boot-sunxi package in Debian.

> Booting U-Boot "automatically" gave me following output:
> usb 0:2...
> Found U-Boot script /boot.scr
> 2458 bytes read in 172 ms (13.7 KiB/s)
> ## Executing script at 43100000
> Mainline u-boot / new-style environment detected.
> 3701296 bytes read in 279 ms (12.7 MiB/s)
> 22913 bytes read in 213 ms (104.5 KiB/s)
> 16438413 bytes read in 916 ms (17.1 MiB/s)
> Booting Debian 4.9.0-3-armmp from usb 0:2...
> ## Flattened Device Tree blob at 43000000
>    Booting using the fdt blob at 0x43000000
>    Loading Ramdisk to 49052000, end 49fff48d ... OK
>    Loading Device Tree to 49049000, end 49051980 ... OK
> Starting kernel ...
> [    1.464003] sr_init: platform driver register failed for SR
> [    2.036209] sunxi-mmc 1c0f000.mmc: smc 0 err, cmd 8, RTO !!
> Gave up waiting for suspend/resume device
> Gave up waiting for root file system device.  Common problems:
>  - Boot args (cat /proc/cmdline)
>    - Check rootdelay= (did the system wait long enough?)
>  - Missing modules (cat /proc/modules; ls /dev)
> ALERT!  /dev/disk/by-uuid/3b34108b-a873-43c6-be7d-95c091c22335 does not exist.  Dropping to a shell!
> ...and dropped me to an initramfs shell.
> The output of "cat /proc/cmdline" is:
> console=ttyS0,115200 quiet
> With my limited U-Boot knowledge I have reached a dead end. I think I
> have to point U-Boot and the kernel to the rootfs on usb 0:3 - but don't
> know the right commands.

If it didn't detect the rootfs, it's probably missing the kernel modules
needed in the initramfs for the drivers needed to use USB. It may have
some of the modules, but be missing things like regulators, so simply
specifying other bootargs u-boot prompt is unlikely to resolve the

> I would aprreciate a pointer in the right direction. Please let me know
> if you need additional information.

Try running lsmod (or cat /proc/modules) to see what modules are loaded.

I'll try and carve out a bit of time to test this myself in the coming

live well,

Attachment: signature.asc
Description: PGP signature

Reply to: