[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

arm64 port blocking packages - help welcome

The arm64 port is now open in the main archive and the initial
(build-essential) bootstrap set of packages was uploaded on friday. We
expect official buildds to come online this week and start churning
through the rebuild of everything.

Meanwhile the debian-ports archive is at 84.5% built, having been
hovering tantalisingly close to the official qualification percentage
of 85% for the last couple of weeks. (I think we'll be past that
tomorrow sometime as 180 packages are currently queued).

However there are some packages that do not yet build from the debian
sources (well, there are at least 575 of those, but some are more
important than others in bootstrapping terms).

This list (generated once/day automatically):
https://people.debian.org/~wookey/bootstrap/blockerlist shows packages
which are out of date or not present at all and the number of packages
which depend on them (indirectly). All the '14,000-odd' ones are in
the SCC (strongly-connected core) and thus bootstrap-vital.

Time is very short for bootstrapping arm64 in time for Jessie so
anyone who can help out is very welcome. (I'm now pre-occupied with
prep for the bootstrap/cross sprint next weekend so have run out of
time for much more poking on this until debconf).

Here is a summary of the status of the top 10:

TL;DR. Someone Please look at qt4-x11 -fpermissive issue, libwebp neon issue, openjade autoconf issue
If we fix those I believe the whole SCC should be buildable.

* libwebp 

 Newly appeared in SCC. Failing to build neon-related files. Needs investigation.

* openjade 

 DebianBug:#748626 Arch-independent breakage. Crufty old source needs
 autofoo updates due to make getting more picky.  I've
 updated/modernised a load of stuff to fix the initial issue and get
 it mostly working, but there is still an issue with a missing make
 target. Current patch is in the bugrep. Someone please take a look.

* gcc-4.9 

 DebianBug:#757153 new upload today should have fixed this. This one
 is the last package needed to get the buildd image up to date.

* keyutils

 DebianBug:#757530 test failures. One lot has been fixed, but now we
 have new ones. This is suspected to be a kernel issue, which will
 hopefully go away on new buildds (or an upgrade to the existing

* kde4libs

 Previously built OK. "out of memory" last time - currently retrying

* qt4-x11

 DebianBug:#735488 This one needs actual work. The existing patches
 are basically fine except for one bit that turns -fpermissive on in
 order to get round some casting complaints and make it build. Needs
 someone with some C++ foo to work out what's actually wrong and fix
 it properly: -fpermissive is not acceptable to the maintainers. There
 was also feedback on the atomics patch which needs replying to.

* qtwebkit

 I patched this weeks ago but seem to have failed to file a bug. Will do that shortly.

 * webkitgtk 
 Has built before. Ran out of memory this time - retrying

 * libprelude

 Has built before. Looks like the build was terminated for inactivity. I just rebuilt it and it worked OK

(Not in the SCC from here on)

 * smpeg

 DebianBug:#757585 Needs re-autoconfing. I sent in a patch and mafm
 sorted out an rpath issue and uploaded within hours (cheers) - so
 that upload is waiting to build, but should be fine

 * gnupg2

 DebianBug:#755061 Tests fail. This is an odd one: gpg-agent only
 works right if built with -O0. It's OK if built on on Ubuntu trusty,
 but those working binaries moved back to Debian still fail tests
 suggesting something else wrong in the environment or a
 library. Needs debugging. don't know if it can be reproduced on qemu?

<all the rest> Feel free :-)

Principal hats:  Linaro, Emdebian, Wookware, Balloonboard, ARM

Reply to: