[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Booting Debian on my Arndale board

Sander wrote:
Phil Endecott wrote (ao):
This has worked, and I have got as far as a login prompt, about twice.  But
normally the boot process seems to stop at some random point, maybe when
"Activating swapfile" or "Cleaning up temporary files".  Sometimes it pauses
for a bit, then makes some more progress, then stops more permanently.

One possibility is that the SATA system has problems.  I will probably try
copying the Linaro Ubunutu root image onto the SSD, and/or copy the Debian
root onto the eMMC, in order to check that.

I have copied the Debian root filesystem onto the eMMC, and I get the same symptoms. So I think the SATA is probably not the problem.

I am wondering if it is something to do with the console driver. Once it has brought up the network, the board is pingable even if the console seems to have locked up. Is there a way to increase the verbosity of the boot messages?

But, if it does finish booting then it seems solid: I can do CPU-intensive and console-intensive stuff without any problems.

For me the (rather old?) kernel from
git://git.linaro.org/people/ronynandy/linux_stable.git also has issues
with sata. In dmesg you'll find a stream of error messages, which you'll
find to be fixed in later kernel version. I don't have the error
messages at hand.

The only error messages spewage that I get is "tty_init_dev: %d callbacks suppressed" - which I think is harmless, per http://lkml.org/lkml/2012/10/5/192.

Is there an "official"
Debian kernel suitable for this board somewhere that I could try instead?

A vanilla kernel.
I've tried to compile vanilla kernels, but can't seem to enable sata

Obviously a vanilla kernel would be great, and it's probably feasible since I'm not interested in many of the exotic features (i.e. graphics). But I don't know how to check whether e.g. the SATA support is even supposed to work in a particular kernel. It would be great if someone in-the-know had some sort of "board status report" indicating per-subsystem which features were upstream in which version, which were only binary blobs, which were in some vendor repo etc. etc. Currently we seem to just try random stuff that Google finds and see what happens.

This was about three weeks ago. Right now the arndale is in the

This purchase was a bit too expensive to leave it "in the corner"...

Cheers,  Phil.

Reply to: