[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ldconfig issue with raspbian, may affect debian too

On Thu, Feb 21, 2013 at 09:53:10AM +0000, peter green wrote:
>Recently eglibc 2.13-38 migrated to debian wheezy and I updated
>raspbian wheezy with it (note: the version in raspbian wheezy is
>2.13-38+rpi1 but the only source change from the debian package is to
>add a few tests to the list of expected failures). This triggered
>some user complaints about the videocore libraries supplied by the
>raspberry pi foundation no longer being found, I presume this is
>related to the ldconfig tagging stuff.
><mike_t> after upgrade libc on raspbian I get problem with
>ld.so.cache. the same problem has already been solved in glibc.
>http://sourceware.org/ml/libc-alpha/2013-02/msg00120.html I hope it
>will be solved in eglibc too

Ummm. The changes that are mentioned there are for glibc 2.17, not
2.13. The bug described there and fixed is to do with handling of new
ELF flags in the latest binutils code. Without those flags (and the
code to match), the code in (e)glibc should be falling back to the old
ARM EABI tags-based recognition of ABI.


>My understanding was that if the easy way to identify a library
>failed debian fell back on using the more painful to read elf tags.

Yes, exactly.

>I grabbed a copy of the library from
>and according to readelf it does appear to have "Tag_ABI_HardFP_use:
>SP and DP"

That's not the one to look for. You want:

  Tag_ABI_VFP_args: VFP registers

which is also set there. "readelf -h" also says

  Flags:                             0x5000002, has entry point, Version5 EABI

What does "ldconfig -p" say for you on problematic system?

Steve McIntyre, Cambridge, UK.                                steve@einval.com
"This dress doesn't reverse." -- Alden Spiess

Reply to: