[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ldconfig issue with raspbian, may affect debian too

Recently eglibc 2.13-38 migrated to debian wheezy and I updated raspbian wheezy with it (note: the version in raspbian wheezy is 2.13-38+rpi1 but the only source change from the debian package is to add a few tests to the list of expected failures). This triggered some user complaints about the videocore libraries supplied by the raspberry pi foundation no longer being found, I presume this is related to the ldconfig tagging stuff.

<mike_t> after upgrade libc on raspbian I get problem with ld.so.cache. the same problem has already been solved in glibc. http://sourceware.org/ml/libc-alpha/2013-02/msg00120.html I hope it will be solved in eglibc too <plugwash> mike_t can you please be specific about exactly what version you updated from and to? <twolife> plugwash: i had an issue yesterday when upgrading libc6 from 2.13-37+rpi to 2.13-38+rpi1 <plugwash> mike_t, you say "the same problem has been solved in glibc" but when I look at your link I just see mails disussing a patch, do you know if the patch has actually been committed? <mike_t> plugwash, see also the bug http://sourceware.org/bugzilla/show_bug.cgi?id=15006#c26 <plugwash> also have you rerun ldconfig since updating eglibc and if so did that make any difference? <mike_t> http://www.sourceware.org/git/gitweb.cgi?p=glibc.git;a=commit;h=b39949d21179bd0b08a083e4f7e35d0c98e11294
<mike_t> yes, I rerun ldconfig. it not helps
<plugwash> mike_t can you run md5sum /opt/vc/lib/libvcos.so
<mike_t> 8bb7da46d40091720947eb67fb992799  /opt/vc/lib/libvcos.so

I'm assuming since at least one of the the libraries is in the cache but isn't found by ldd that it's being misidentified as a softfloat library. What I can't figure out is why.

My understanding was that if the easy way to identify a library failed debian fell back on using the more painful to read elf tags. I grabbed a copy of the library from https://github.com/raspberrypi/firmware/raw/master/hardfp/opt/vc/lib/libvcos.so and according to readelf it does appear to have "Tag_ABI_HardFP_use: SP and DP"

Anyone have any thoughts on this.

Reply to: