[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need help with install Debian on INTEL SS4000-e

LO Henk,

On Thu, Sep 27, 2012 at 09:59:14PM +0200, Henk Smit wrote:


> First I enabled the SSH server on the default NAS software, and
> tried to update the system with the ss4000e.pkg software file (no
> changes to the system). 

(Not usefull/relevant. IIRC, the ss4000e.pkg is intented to be loaded
through the origial web interface of the device.)

> After this I downloaded the Debian installation files from the
> internet (initrd.zg and Zimage). With HyperTerminal and a serial
> cable connected to the NAS. The system reboots and I hit the
> control-C buttons to interrupt the system. To make a clean system I
> did erase the FIS memory by the fis inid command. The hard disk
> cannot be recognized at this moment and there is no connection
> possible via putty.

You shouldn't delete anything at first to install Debian on it, and by
doing this, I think you've deleted the 'rammode' of the device, which
is necessary to get access to the network for installation :-(

> Below are the commands used to write the files in the flash memory:
> - fis init (format all the flash apart from redboot)

Sorry, but not a good idea. You need 'rammode' to install Debian...

> Now the installation begins, after a while I get the following error message
> +No network interfaces found

By doing 'fis load rammode', you'll have gained access to the

> RedBoot> exec -c "console=ttyS0,115200 rw root=/dev/ram mem=256M@0xa0000000"
> -r 0x01800000 -w 5

> [    2.504301] No filesystem could mount root, tried: 
> [    2.509244] Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(1,0)

If I understand right, Debian installer boots correctly, but the root
FS is not in ram anymore (root=/dev/ram) since you wrote it on the
flash, but I'm unsure...

> I hope someone can help me with this problem.

I've several ideas to get you back on the right side, but unsure of
the result.

So I will state them at first, and if nobody objects (perhaps Arnaud
has a better idea ?), you can try them in order :

1. alter the boot exec line to mention the correct root=<device>
   instead of /dev/ram.

   Your initrd should be on one of the mtdblockX listed by d-i :

[    2.475118] List of all partitions:
[    2.478788] 1f00             256 mtdblock0  (driver?)
[    2.483889] 1f01            4352 mtdblock1  (driver?)
[    2.489010] 1f02            1408 mtdblock2  (driver?)
[    2.494104] 1f03               4 mtdblock3  (driver?)
[    2.499216] 1f04             128 mtdblock4  (driver?)

   My guess is for the second one, if creation of the blocks follows
   the before list in same order :

[    2.333736] Creating 5 MTD partitions on "physmap-flash.0":
[    2.339375] 0x000000000000-0x000000040000 : "RedBoot"
[    2.347736] 0x000000040000-0x000000480000 : "ramdisk.gz"
[    2.356682] 0x000000480000-0x0000005e0000 : "zImage"

   Ramdisk seems to be the second one.

   So try to issue the following exec line :

RedBoot> exec -c "console=ttyS0,115200 rw root=/dev/mtd1 mem=256M@0xa0000000" -r 0x01800000

   But : a) I'm not sure at all it will work (the partition /dev/mtdX
   doesn't seem to be recognized from the list above which state

   b) trying also the other ones won't hurt (mtd[0-4]), just in case ;

2. reinstall the IPStor crap, with the supplied CD-Rom, and restart
   cleanly from there.

   You'll need a Window$ machine and in theory, the software on this
   CD should be able to detect the misfunctionning of the nas and
   restore the missing files on the flash.

3. simply copy a original rammode file (and perhaps other files too)
   from another same nas ?
   You seem to be confident with fis unlock/create commands and can
   perhaps restore manualy the content of the flash, to go from a
   known and clean state ?

It's just some ideas...

The 1 can be tried. At worst, it won't work.

But for the 2 et 3, since they alter the flash, my advice is to wait a
couple or hours for possible comments from the list before trying

Hih though,



Reply to: