[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help needed after updating Debian on QNAP TS-109 Pro II


I ran both of those now but I still have not dared to reboot because starting cupsd seems to hang forever. I am concerned that my boot could get stuck.

This is what it is running:

13874 pts/9    S+     0:00                      \_ /bin/sh /usr/sbin/invoke-rc.d cups start
13890 pts/9    S+     0:00                          \_ /bin/sh /etc/init.d/cups start
13897 pts/9    S+     0:05                              \_ modprobe -q -b parport_pc

Any ideas? I suspect this might also be related to why smbd crashes. Or should I just take the leap and reboot?


On Sat, Sep 22, 2012 at 11:03 PM, Björn Wetterbom <bjohv052@gmail.com> wrote:

Wait! You must also run flash-kernel as root to move the initramfs to flash. Sorry I missed that.


(Sent from my phone.)

On Sep 22, 2012 9:57 PM, "Björn Wetterbom" <bjohv052@gmail.com> wrote:

You should have no problems. The part about boot loader is because grub or lilo can't be found. That's normal since you boot from flash.

Run update-initramfs -u as root before reboot and you will be fine. I'm not sure it's needed nowadays, but it certainly won't cause any harm.


(Sent from my phone.)

On Sep 22, 2012 9:48 PM, "Juha Larjomaa" <juha.larjomaa@iki.fi> wrote:

I have been happily running Squeeze from a USB stick on my QNAP TS-109 Pro II for a long time. Today, I decided to update my system with 'apt-get upgrade'. Some packages were updated but I saw that some files were "kept back" by apt-get - so I decided to run 'apt-get dist-upgrade' without knowing any better.

This is when problems started. Would anyone be able to help?

Apparently the update changed the mgmt of hard disks to some UUID-based plot that I am not familiar with. For example, my /etc/fstab was changed as follows:

kaappikone# less /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda2       /               ext3    errors=remount-ro,noatime 0       1
UUID=59c82707-e5bd-4538-a2ad-b697635e9313       /               ext3    errors=remount-ro,noatime 0       1
# /dev/sda1       /boot           ext2    defaults        0       2
UUID=42cacc9b-4dfd-4cd9-85dc-8810a82af109       /boot           ext2    defaults        0       2
# /dev/sda5       none            swap    sw              0       0
UUID=0f4c0b92-afd9-45de-b9b1-40b93d458ffa       none            swap    sw              0       0
# /dev/sdb2       /bigdisk      ext3    noatime         0       1
UUID=af48689a-1f86-4a8b-ab86-be90915b37d9       /bigdisk        ext3    noatime         0       1

The bit that worries me is that the upgrade program gave me the following warning:

 │ Boot loader configuration check needed                                    │ 
 │                                                                           │ 
 │ The boot loader configuration for this system was not recognized. These   │ 
 │ settings in the configuration may need to be updated:                     │ 
 │                                                                           │ 
 │  * The root device ID passed as a kernel parameter;                       │ 
 │  * The boot device ID used to install and update the boot loader.         │ 
 │                                                                           │ 
 │                                                                           │ 
 │ You should generally identify these devices by UUID or label. However,    │ 
 │ on MIPS systems the root device must be identified by name.   

Would anyone be able to help me how to do that? Or, more generally, how to ensure that my QNAP box will be able to boot again?

I have not yet rebooted since the update. I am able to login with SSH but for some reason smb crashes as soon as I try to connect to it. This did not happen before the update.



Reply to: