[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot boot Freestor 4020 (SS-4000E)


On Fri, Jul 13, 2012 at 01:08:44PM -0400, Chris Wilkinson wrote:


> Does anyone know if 7220/4020 versions are available anywhere?

I don't believe it, but the SS4000E version seems to work, at least to
a large extend.

> It hangs on boot but boots from the console using fis load, exec.
> There is one disk is inserted which is disk1/4 of what was the RAID5
> set.
> Not sure what to try next to get it to boot on its own.

Perhaps to modify the boot script ?

Could you report here what's in it for now ?

You should play a bit in redboot to find the command to report its

> EM-438/EM-7220 ver.AG0 2006-05-23
> == Executing boot script in 1.000 seconds - enter ^C to abort
> RedBoot> fis load ramdisk.gz
> RedBoot> fis load zImage
> RedBoot> exec
> Using base address 0x01008000 and length 0x00200000
> Uncompressing Linux... done, booting the kernel.
> <<hangs here>>

How are you sure that it hangs ?

It can also be that it doesn't report anything to the serial console

If the « console=ttyS0,115200 » part is not in the exec cmdline, you
will see nothing on the serial console...

(But you should see the login prompt at the end of the boot process,

> If I start from the console it boots. So it seems the fis images are
> OK.


> RedBoot> exec -c "console=ttyS0,115200 rw root=/dev/ram mem=256M@0xa0000000"
> -r 0x01800000 -w 5

Your machine seems to boot normally with this exec cmdline.

So the idea is to put this line in the boot script.




Reply to: