[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to install Debian on MCIMX53-START-R


On 6/29/12 5:31 PM, Arnaud Patard (Rtp) wrote:
Gregor Jasny <gjasny@googlemail.com> writes:
I'd like to install Debian onto my i.MX53-R board. I tried to follow
http://wiki.debian.org/InstallingDebianOn/Freescale/QuickStart but the
linaro-hwpack-create command failed with a python error mentioning
that linux-image-3.1.0-1-mx5 was not found.

unstable is using 3.2:

Thank you for this hint. I was able to build an image and dd'ed it to the micro SD card. On the serial console I could watch the boot process but noticed some warnings and errors:

[ 1.248177] /build/buildd-linux_3.2.21-3-armhf-ki0aTS/linux-3.2.21/drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[ 2.221226] _regulator_get: sdhci-esdhc-imx53.0 supply vmmc not found, using dummy regulator [ 2.265722] mmc0: SDHCI controller on sdhci-esdhc-imx53.0 [sdhci-esdhc-imx53.0] using DMA [ 2.401097] _regulator_get: sdhci-esdhc-imx53.2 supply vmmc not found, using dummy regulator

As far as I can see the second revision (-R) of the loco board is not properly supported. The vanilla kernel lacks (at least) the MC34708 PMIC related drivers. So USB and sometimes VGA are not working properly.

I tried to backport the MC34708 patches from the Freescale kernel tree but gave up because the trees diverged too much.

The necessary patched can be found here (2011-10-27):

I also made the mistake to flash the Wheezy image to a micro SD card and tried to boot from the SATA disk with the Debian u-boot. Unfortunately it lacks SATA support for the loco board (This was introduced in a later u-boot version than the one on Wheezy).

I wonder if it's possible to use the Freescale 2.6.35 kernel to run the Debian armhf port. Will this work? Or must I use the armel port?

Thanks for your help!

Reply to: