[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

still trouble with the NSLU2

Dear Martin, dear all,

I think I have been a bit over-optimistic on my NSLU 2 in my post a  few
hours ago. I was very happy that the slug was  actually  booting  and  I
though that all the troubles were over. However, that was not the case.

I followed closely all the instructions on Martin's page[0]

and everything went well. I even managed to do an  'apt-get  update'  to
switch to the italian servers. However, as soon as I ran 'apt-get  dist-
upgrade' I got a segfault while running the 'Building  dependency  tree'
at around 6 %. I also tried to install a few packages (like sudo  etc.),
but 'apt-get install' segfaults always when 'Building dependency tree'.
Thinking that it was a memory allocation problem I verified that my swap
device was on (as a matter of fact I even added another swap file to make
doubly sure things could run) and swapon -s says:

Filename              Type           Size      Used       Priority
/dev/sda5             partition     2097144    7012         60
/var/local/swapfile   file           527992       0         -1

so I really don't even get near memory exhaustion. If apt-get doesn't work,
there's hardly anything I could do with this machine, right?

Can someone please tell me what's wrong? Or is it the hardware  that  is
dying? (Note: the disk is a brand new 2.5 external HDD  without  external
power supply: could this be the problem?)

Thanks again for the great work


[0] http://www.cyrius.com/debian/nslu2/unpack.html

Nicola Bernardini
Scuola di Musica Elettronica
Conservatorio C.Pollini Padova
e-mail: nicb@sme-ccppd.org
GPG fingerprint = 6AE6 AF21 E160 D9B3 396E  EBAC 906C CFAE 4D65 D910
Neither MS-Word nor MS-PowerPoint attachments please.

Reply to: