[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

I can't make my NSLU2 boot with Debian squeeze (nor any other release for that matter) :(

Dear all,

I am new to this list - sorry I tried not to bother anyone in setting up
an (old) NSLU2 with Debian but I've failed all attempts  and  I  do  not
know what to try any longer. I have looked at all  possible  sources  of
info but they did not help me making any progress. Sorry that this seems
to be an old problem, but I can't find the solution.

First, I tried to  install  Debian  proper  following  Martin  Michlmayr
instruction here[0]. It wouldn't go past the "all four  leds  on"  stage
(top led yellow). So I followed a hint and opened the case  and  removed
the RTC battery. And  voilà,  the  di-nslu2.bin  (taken  from  here[1])
suddendly booted and started the installer. So I logged in  and  started
the installation process. Unfortunately, it won't complete. I tried many
times but I couldn't go past the "Install the base  system"  stage.  The
(direct, wired) ssh connection would drop and when reconnecting, I would
have to start the "Install the base system" stage again and  so  I  went
nowhere with that method. One  good  thing  was  that  the  machine  was
immediately (so to speak) available on  the  network  at  the  canonical

So I switched to another page from Martin's, the one  that  suggests  to
install a Debian 6.0 tarball on  an  external  disk,  then  upslug  this
squeeze image[2] and boot from there. This time, the leds do  the  usual
boot routine, then only the network led remains lit and the machine goes
into meditation mode and is hardly accessible from outside (yes, I  also
checked with nast -m to make sure that it did not get  an  IP  address).
The attached disk doesn't show any activity, so it looks like  the  boot
doesn't even get to fsck it or whatever. I waited also for entire nights
for the device to boot, but to no avail. I set up the  bootlogd  default
to yes, but of course since it doesn't get  to  the  disk  nothing  gets
written on it. Nor read, for that matter. I tried with and  without  the
RTC battery, no show.

Just for the  record,  here's  how  the  external  disk  is  partitioned
(following Martin's instructions):

Disk /dev/sdd: 203.9 GB, 203927060480 bytes
255 heads, 63 sectors/track, 24792 cylinders, total 398295040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe3b593ff

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *        2048    10506509     5252231   83  Linux
/dev/sdd2        10506510    73449179    31471335   83  Linux
/dev/sdd3        73449180   398283479   162417150    5  Extended
/dev/sdd5        73451228    73818674      183723+  82  Linux swap / Solaris
/dev/sdd6        73820723   398283479   162231378+  83  Linux

(this is from reading on my laptop: I have  another  external  disk,  so
this ends up being /dev/sdd).

At the end of loading the base system tarball[3] (yes I have checked that the
signature is correct) here is what a df looks like:

Filesystem           1M-blocks      Used Available Use% Mounted on
/dev/sdd1                5049M       15M     4778M   1% /home/nicb/mnt/boot
/dev/sdd2               30251M      673M    28042M   3% /home/nicb/mnt/mnt
/dev/sdd6              155943M      188M   147834M   1% /home/nicb/mnt/home

/boot is an ext2 filesystem,  all  others  are  ext3  (as  per  Martin's
instructions). By looking at the mailing-list I also tried other things,
like setting  up  volume  labels  and  exchanging  the  boot  flag  from
/dev/sdd1 to /dev/sdd2. Everything without success, unfortunately.

What am I doing wrong? I don't have a serial port and am not  that  good
at hacking hardware... what can I do to get this going?

Thanks to all for your excellent work (I wish I could use it!)


[0] http://www.cyrius.com/debian/nslu2/install.html
[1] http://www.slug-firmware.net/d-dls.php
[2] http://www.cyrius.com/debian/nslu2/files/armel/sda2-2.6.32-5
[3] http://people.debian.org/~tbm/nslu2/squeeze/base.tar.bz2

Nicola Bernardini
Scuola di Musica Elettronica
Conservatorio C.Pollini Padova
e-mail: nicb@sme-ccppd.org
GPG fingerprint = 6AE6 AF21 E160 D9B3 396E  EBAC 906C CFAE 4D65 D910
Neither MS-Word nor MS-PowerPoint attachments please.

Reply to: