[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: armhf installer status?


On Wed, 13 Jul 2011, Hector Oron wrote:


2011/7/12 PALFFY Daniel <dpalffy@rainstorm.org>:

I'm trying to install debian on an mx53loco board. I have built a custom
kernel from the linaro 2.6.38 sources, with most important drivers built in,
it worked fine with the versatile armel installer initrd, after manually
installing the kernel, running mkimage and setting up the bootloader,
everything works fine. I've tried using both the efika initrds from
http://people.debian.org/~zumbi/di-armhf/mx5/netboot/genesi/ (the only armhf
installer I could find) and building an initrd in a debootstrapped armhf
chroot, both fail when trying to download installer components from the
mirrors, without telling which file they were missing.

Are these images broken only on my hacked kernel, or is this a known

Debian does not (yet) support mx53 LOCO boards, while patches are
welcome I would suspect, at least I would try to help getting those
into place (I am still waiting for one of those boards to arrive
here). Phil Endecott has already had the pleasure to get that device
running, and you are probably welcome to check his notes at:

Most of the system works fine for me, too, but since i'd like to use LVM, crypto, etc on the HDD, i'd rather set things up with the installer than with debootstrap and hand editing files...

Regarding debian-installer on armhf, most of the support is already
there, but some bits are still leaving in branches, some other
packages need to be released and some other bits depend on other bug
fixes, for example, flash-kernel, the tool generating u-boot format
images for kernel and initrd does not handle hooks properly yet. I
tried to look into fixing that, but I got stuck on initramfs-tools not
calling hooks upon initrd create and delete, it only calls hooks on
upgrade. There was some discussion at debian-kernel mailing list [0]
about it. So basically, status is most support is there, but we need
to wait a little and be patient. I'll try to give it another try soon
and let the mailing list know about it.

Ok, this is again no problem for me - the armel installer had these too. I just booted an mx53loco kernel with the versatile netboot installer initramfs, and at the end of the install, chrooted into /target, installed my kernel deb, ran mkimage, etc. This is what I wanted to do with armhf too, but the installer was missing files on the mirror (tried to build the latest d-i git, too, with the same results). I was interested if the efika images work for you (at least until installing the base system)?


			...and Linux for all.

Reply to: