[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

re: bug 623747 svgalib: FTBS on armel

Note: I write this message to the bug as a concerned user of freepascal in debian.

Currently in debian the svgalib packages themselves are marked as being for architectures linux-any and kfreebsd-any but packages-arch-specific restricts building on the buildds to i386 and amd64. Further at least on armel the current source FTBFS.

The submitter of this bug has supplied a patch and with that patch applied svgalib compiles on armel.

The lack of svgalib packages on armel is currently rendering fp-units-gfx-2.4.2 uninstallable on armel. Afaict uninstallable packages are a RC issue.

I see two ways of fixing the uninstallability.

1: apply the patch the submitter of this bug supplied and change packages-arch-specific allow the buildds to build svgalib on armel (and possiblly other architectures). 2: modify the freepascal packaging to eliminate the dependency on the nonexistant binary package

What i'm not sure on is which is the correct path. I know there have been arm boxes that use PC graphics hardware in the past but I don't know if they are compatible with svgalib or indeed whether they are compatible with the debian armel port.

Depending on the responses I get I will either raise the severity of this bug or file a new rc bug against fp-units-gfx-2.4.2

Reply to: