[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Redboot won't load initrd.gz via ymodem

Hi all,

Ok so I tried to install debian using the procedure outlined in the
debian-installer docs for the arm architecture, however something went
wrong and I had to abort the install process. When I tried to follow the
procedure again the process just hangs after loading the initial ramdisk.
(I think)

I then tried to clear the flash by doing a "fis init" and trying to
recreate the flash image with

fis unlock -f 0xf02c0000 -l 0x00400000
fis create -b 0x01800000 -f 0xf02c0000 -e 0x01800000 -r 0x01800000 ramdisk.gz
load -v -r -b 0x01800000 -m ymodem initrd.gz

I would dot he same with the zImage as well if I can get this to work. The
problem is that the initrd.gz image wont download via ymodem. I am using
minicom. I wait for a "C" to show then do the c-A S thing to send the file
but it just times out. First time using minicom so maybe I don't know how
to use it properly.

Does anyone know whats going on?


Reply to: