[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: alignment errors on armel: what to do?

On 9/28/09, Daniel Kahn Gillmor <dkg@fifthhorseman.net> wrote:
>  i just turned on warnings in an NSLU2 running squeeze (a buildd for me)
>  and note alignment warnings from several processes:
>   pdftex (reproducable with "aptitude reinstall texlive-base-bin")
>   aptitude (also reproducable with "aptitude reinstall texlive-base-bin")
>   apt-extracttemplates (reproducible with "apt-extracttemplates
>  /var/cache/apt/archives/patchutils_0.3.1-2_armel.deb" or any .deb)
>   grotty (reproducible with "man gpgv")
>   gpgv (reproducible during "aptitude update", haven't narrowed it down
>  further)
>   /usr/lib/apt/methods/http (reproducible during "aptitude update", also
>  haven't narrowed it further)

OK. I've added a section to http://wiki.debian.org/ArmEabiProblems
listing the affected programs (the above and a couple of others I've
My reason for doing this, instead of just filing bugs, is that while
you're chasing one down, others pop up, so this forms a kinds "todo"
list. The fixes are usually trivial when you find them: add
__attribute__((aligned(4))) to something.
Ideally I see the items in this getting annotated with the bug numbers
when they're filed and removed when they are resolved.

Does that sound like a reasonable way to tackle them?


Reply to: