[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

NSLU2 not mounting root filesystem after the ramdisk has been updated

Hi list,

I successfully installed debian etch on a NSLU2. That was very easy,
thank you very much.

I have though a problem that is certainly easy to solve, but since I
am new to this kind of hardware, I am a bit stuck.

I upgraded the system to a mixture of testing /  sid. I notice that
every time the ramdisk is updated (change in initramfs-tools, or other
tools, or a new kernel), the system after a reboot is unable to mount
the root file system (on a USB hard drive). I see the cycling green
leds, then the amber led + ethernet led, then the orange led +
ethernet, and that is all.

I read in the README.Debian of package nslu2-utils that the system
loaded the initramfs, but then is stuck. I have to reset the slug and
flash with upslug a backup image I made just after the installation.

I tried to compare the backup image and the image not booting
properly. I extracted the different parts with slugimage -u, and the
ramdisk.gz are reported to be different (the other files are the

I tried then to uncompress the ramdisk.gz to see where the difference
is, using devio but I got this :

$ devio '<< ramdisk.gz; xp $ 4' > ramdisk-swap.gz
devio: xp $ 4: invalid byte count
zsh: exit 1     devio '<< ramdisk.gz; xp $ 4' > ramdisk-swap.gz

Can anyone help me on this ?

Thanks in advance,


Reply to: