[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing debian-armeb on a new device / where to get the base filesystem?

Andreas Barth wrote:
* Martin Michlmayr (tbm@cyrius.com) [060523 13:08]:
* Tomasz Chmielewski <mangoo@wpkg.org> [2006-05-23 12:43]:
It runs some sort of Linux (big-endian), but I thought it would be a
better idea to try to run Debian-armeb on this device.

To do this, I would need some sort of a "base filesystem" of a
Debian-armeb installation - that is, a minimal install, to which I
could chroot.
There's one in http://armeb.debian.net/debian-armeb/project/ but it's
a) slightly broken and b) out of date.  Maybe it can be updated.

One could of course use debootstrap. And, if there should be a newer
chroot tarball, you might put a newer tarball somewhere and send me
(signed) md5sums and location, and I'll put it on there also.

Hmm, it seems it's problematic with debootstrap.

I tried it on a x86 machine, and on this armeb device, using http://armeb.debian.net/ and http://ftp.debonaras.org/ mirrors. Unfortunately, it seems that some packages are missing, because debootstrap was always throwing and error at some point (missing libgnutls, gcc etc.).

I tried sarge and sid, but I couldn't make a base filesystem due to missing packages.

The other thing I did was to use the ready images mentioned.

There I got stuck again, I was able to chroot into them, everything works fine, but any usage of dpkg ends with "segmentation fault" (dpkg --help" works, but "dpkg -l" will segfault. Other tools seem to work fine.

I tried different versions of dpkg available for armeb, but they all fail in the same manner.
strace gives no clues either, dpkg just segfaults at the same point:


open("/etc/dpkg/dpkg.cfg", O_RDONLY|O_LARGEFILE) = 3
fstat64(3, {st_mode=S_IFREG|0666, st_size=294, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40015000
read(3, "# dpkg configuration file\n#\n# Th"..., 4096) = 294
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40015000, 4096)                = 0
brk(0)                                  = 0xe2000
brk(0)                                  = 0xe2000
brk(0xe1000)                            = 0xe1000
brk(0)                                  = 0xe1000
open("/home/toor/.dpkg.cfg", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Any clues?

Tomasz Chmielewski

Reply to: