[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#270202: qt-x11-free build error on arm-linux

> Starting program: /home/matthias/qt/qt-x11-free-3.3.3/bin/uic -L plugins
tools/designer/designer/pixmapfunction.ui -o$
> [Thread debugging using libthread_db enabled]
> [New Thread 16384 (LWP 31697)]
> Program received signal SIGINT, Interrupt.
> [Switching to Thread 16384 (LWP 31697)]
> 0x40506024 in mult () from lib/libqt-mt.so.3
> the process uses all CPU time, strace doesn't show any
> output. suspecting a toolchain issue, the following combinations of

I'm not using Debian ARM, so I'm not too sure if this reply will be of
much help; however, I had the exact same problem building qt-3.3.3 for my
Slackware ARM port.

To fix it I patched in:
from qt-x11-free_3.3.3-4.1.diff.gz

and added -DQT_QLOCALE_USES_FCVT as an argument to ./configure
because this is what debian/rules does in this particular diff version
(and it's also mentioned in the diff's changelog).

I built qt with:
glibc-2.3.2 (with Debian's diff - sorry, can't remember which one
specifically but it was *probably* diff-16)

If it's any help then I can let you know exactly what toolchain versions
I'm currently using (including any Debian diffs I use (I only apply
full Debian diffs to glibc and gcc)) and I will rebuild qt-3.3.3 and let
you know the results.

If it's of any use or interest then the build log for a completed build of
qt can be found here:
The main build script is here:

Stuart Winter
www.interlude.org.uk & www.armedslack.org

Reply to: