[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.19 crashes, 16 bpp framebuffer

Hello again,

After about a week of uptime without X, I fired up X yesterday, and had another crash last night. Like last time, X was in gdm with dpms blanking the monitor. Unlike last time, this was not caused by the laptop's network cable, but happened when my wife's already-connected PC with XP tried to access the net after a couple of hours of idle network time.

One other thing: I run noflushd to spin down the hard drive when idle. I also turn the fan off in the winter, as it's in a cool spot and the CPU never goes above 50 C; it's nice to have a small silent low-power always-on router-firewall-server that also serves as an X terminal/desktop, though I've given up on 16 bpp and use 1600x1200x8 now...

Though for that last purpose (X desktop), I'm afraid this new kernel is just too unstable for me, so I'm going back to 2.4.16. If anyone has an idea of how to debug this, I'd be happy to go back to 2.4.19 for that purpose.

Adam C Powell IV wrote:

My Netwinder has had two crashes since upgrading to Othmar's 2.4.19 kernel-image packages. It previously had several months of uptime with 2.4.16 kernel-image from stable.

The machine is an ipmasq box for a small home network on a hub, with the following modules installed: parport_pc, lp, parport, af_packet, slip, ipchains, waveartist, sound, soundcore, fbcon-cfb16, tulip, ne2k-pci, 8390. It runs dhcp for the home network, dhcp-client to get its address from the cable modem, apache, samba, and is a part-time desktop running X 4.2.1 with GNOME 2 in an unstable chroot. (I hadn't known you could do X in a chroot, but it works.)

So the two times it crashed, I was doing net stuff on my laptop, and suddenly the net connection went down. Both times the connector to my laptop (the little cable thingy between the RJ45 and the laptop net port) was partly out, and I plugged it back in, but still couldn't connect because the netwinder had crashed.

Also, both times X happened to be running, the first time with GNOME 2 running, the second just sitting in gdm. No idea whether this did anything. And both times, dpms had shut down the monitor, and turning it on and hitting keys didn't help -- no oops in sight.

This same thing had happened several times before with 2.4.16, but no crash. Could there be a partial-packet exception crashing the kernel? I don't see how such a thing could be ARM-specific, since AFAIK all of the net code is in C, and I'm sure others would have seen it on other platforms... I haven't tried to reproduce it, will do so if it would help debug, but in the meantime the coincidence is pretty striking.


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe! <http://lyre.mit.edu/%7Epowell/The_Best_Stuff_In_The_World_Today_Cafe.ogg>

Reply to: