[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

atlas, lapack on arm

Greetings!  Was wondering if you get help me with these two packages
on arm.

1) lapack:  from the autobuilder:

g77  -c -funroll-all-loops  -ff90 -O3 stzt01.f
g77  -c -funroll-all-loops  -ff90 -O3 stzt02.f
g77  -c -funroll-all-loops  -ff90 -O3 slaord.f
g77   aladhd.o alaerh.o alaesm.o alahd.o alareq.o alasum.o alasvm.o chkxer.o icopy.o ilaenv.o xlaenv.o xerbla.o slaord.o schkaa.o schkeq.o schkgb.o schkge.o schkgt.o schklq.o schkpb.o schkpo.o schkpp.o schkpt.o schkq3.o schkql.o schkqp.o schkqr.o schkrq.o schksp.o schksy.o schktb.o schktp.o schktr.o schktz.o sdrvgb.o sdrvge.o sdrvgt.o sdrvls.o sdrvpb.o sdrvpo.o sdrvpp.o sdrvpt.o sdrvsp.o sdrvsy.o serrge.o serrgt.o serrlq.o serrls.o serrpo.o serrql.o serrqp.o serrqr.o serrrq.o serrsy.o serrtr.o serrtz.o serrvx.o sgbt01.o sgbt02.o sgbt05.o sgelqs.o sgeqls.o sgeqrs.o sgerqs.o sget01.o sget02.o sget03.o sget04.o sget06.o sget07.o sgtt01.o sgtt02.o sgtt05.o slaptm.o slarhs.o slatb4.o slattb.o slattp.o slattr.o slavsp.o slavsy.o slqt01.o slqt02.o slqt03.o spbt01.o spbt02.o spbt05.o spot01.o spot02.o spot03.o spot05.o sppt01.o sppt02.o sppt03.o sppt05.o sptt01.o sptt02.o sptt05.o sqlt01.o sqlt02.o sqlt03.o sqpt01.o sqrt01.o sqrt02.o sqrt03.o sqrt11.o sqrt12.o sqrt13.o sqrt14.o sqrt15.o sqrt16.o sqrt17.o srqt01.o srqt02.o srqt03.o srzt01.o srzt02.o sspt01.o ssyt01.o stbt02.o stbt03.o stbt05.o stbt06.o stpt01.o stpt02.o stpt03.o stpt05.o stpt06.o strt01.o strt02.o strt03.o strt05.o strt06.o stzt01.o stzt02.o \
        ../../tmglib_LINUX.a -L /build/buildd/lapack-3.0.20000531a -llapack -lblas  -o ../xlintsts
../../tmglib_LINUX.a(slatms.o): In function `slatms_':
slatms.o(.text+0x974): undefined reference to `.LC12'
slatms.o(.text+0x97c): undefined reference to `.LC14'
slatms.o(.text+0xda4): undefined reference to `.LC12'
slatms.o(.text+0xdac): undefined reference to `.LC15'
slatms.o(.text+0x1314): undefined reference to `.LC15'
slatms.o(.text+0x1834): undefined reference to `.LC15'
slatms.o(.text+0x1d00): undefined reference to `.LC12'
slatms.o(.text+0x1d08): undefined reference to `.LC15'

   Here libblas and liblapack are shared libs.  One can build an
   executable without PIC and then link to a PIC shared lib on arm,

2) atlas:   Atlas times various routines to pick the most efficient
   for the host in question.  All timings on arm are so varied that
   the build fails being unable to get timing values within the
   required precision.  Atlas can use several timers, rusage, wall
   time, clock, etc.  The default is rusage (cpu), and this is the one
   I've tried.  On mips, using 3.0 helped a great deal over 2.95, but
   don't know why.  Have only tried the default compiler on arm.  

Thanks in advance for any suggestions!

Camm Maguire			     			camm@enhanced.com
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

Reply to: