[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Uh oh, NeTTrom upgrade error!

On Fri, 16 Feb 2001, Adam C Powell IV wrote:

> I was just trying to upgrade my nettrom, using 2.3.3 extracted from the rpm,
> and flashwrite from corel-util 1.2-2, running kernel-image-2.2.13-netwinder.
> I modprobed nwflash, but there was no /dev/nwflash and MAKEDEV didn't make one
> (bug?), so I checked the /dev entry in the RedHat partition and did:
> mknod /dev/nwflash c 10 160

That is correct.  You might also want to create a symlink /dev/flash, but
I don't believe it is necessary.  I have:
  [root@stewart-nw15 redhat]# ls -l /dev/*flash*
  lrwxrwxrwx    1 root     root            7 Nov 11 12:50 /dev/flash ->
  crw-------    1 root     root      10, 160 Nov  8 15:10 /dev/nwflash

Use flashwrite from the nettrom-2.3-3 rpm package.  The one from
corel-util may be 'really, really' old.

Did you reinstall the module after creating the device?  This may be

rmmod nwflash
modprobe nwflash
./flashwrite -base64 nettrom-2.3.3.bin 0

Hopefully this will work...

> so ls -l looked the same on both partitions.  Then I ran:
> flashwrite nettrom-2.3.3.bin 0
> and after consenting to flash with "y", it gave the LED message, then
> immediately:
> ERROR: flash write returned error -1!
> Thinking the behavior was nettrom-version-dependent, I tried to rewrite
> 2.1.24, then 2.0.6, which both gave the same error!

No the behaviour is not nettrom version dependent...

> So, am I hosed?  Can I reboot safely?  Do I need to run this under a newer
> kernel?  How can I check the integrity of the nettrom in flash?

Hopefully what I said above will help...  If not let me know,


Reply to: