[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Uh oh, NeTTrom upgrade error!


I was just trying to upgrade my nettrom, using 2.3.3 extracted from the rpm,
and flashwrite from corel-util 1.2-2, running kernel-image-2.2.13-netwinder.
I modprobed nwflash, but there was no /dev/nwflash and MAKEDEV didn't make one
(bug?), so I checked the /dev entry in the RedHat partition and did:

mknod /dev/nwflash c 10 160

so ls -l looked the same on both partitions.  Then I ran:

flashwrite nettrom-2.3.3.bin 0

and after consenting to flash with "y", it gave the LED message, then

ERROR: flash write returned error -1!

Thinking the behavior was nettrom-version-dependent, I tried to rewrite
2.1.24, then 2.0.6, which both gave the same error!

So, am I hosed?  Can I reboot safely?  Do I need to run this under a newer
kernel?  How can I check the integrity of the nettrom in flash?


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

             Welcome to the best software in the world today cafe!

Reply to: