[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: compiler broken



Philip Blundell wrote:

> In message <8658394a4a%peter@erble.freeserve.co.uk>, Peter Naulls writes:
> >You don't say what kernel you're using, but the current GCC certainly
> >has a problem on 2.2.16-rmk3 kernels.   You could try 2.4, or downgrade
> >GCC as Phil suggested.
>
> I'm pretty confident the kernel isn't at fault here.  But, if people want to
> try, there are 2.2.18 and 2.4.1 packages for netwinder and RiscPC in the lkab
> output directory on ftp.armlinux.org.

Interesting, I'm using an older gcc (from potato I think, not gcc-2.95 anyway)
with libc6 2.2.1 and kernel 2.3.99-pre8-rmk1 and it just built the latest
openssh just fine. :-)

Oh- and using CXX=g++-2.95 with the old gcc allowed db to build successfully
too, though I noticed afterward that binaries already existed, and got those
(rather than have to possibly debug a mixed-compiler problem :-).

Just FWIW,

-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

              Welcome to the best software in the world today cafe!



Reply to: