[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gcc 2.95.2-13 for arm

On Sun, Aug 27, 2000 at 04:50:51PM -0400, Chris Gorman wrote:
> I think you may be correct (at least on arm).  If you are successfull with
> Phil's suggestion (building srpm gcc) post a report to the list.  (I for
> one would like to get an update on this.)  

I unpacked the SRPM on an x86 running Debian, then tared up the directory
and shipped it back to my RISC PC on a zip disk.

After an initial problem of not having autoheader (so I downloaded autoconf -
should gcc's ./configure be checking for this, or in the non patched versions
are the headers shipped pre-made, or was it because I issued make distclean
or something like that at one point on the PC?) things seemed to progress

It goes in an infinite loop when I issue
make CC="stage1/xgcc -Bstage1/" CFLAGS="-g -O2"

printing (over 10240 times):
/tmp/ccEgxiFQ.s:444: Warning: Missing section name
when making gcc.o

For anyone who is interested I've uploaded /tmp/ccEgxiFQ.s to


The file itself seems to pass through
as   -o ccEgxiFQ.o ccEgxiFQ.s

as --version
GNU assembler 2.9.5
Copyright 1997 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License.  This program has absolutely no warranty.
This assembler was configured for a target of `arm-linux'.

The second time round (make using the stage2 compiler) there were different
errors at the same point, but again when I ran the command by hand it worked.
So I have little idea of the cause of all this, but it may not be gcc.

However, when I had made the compiler again, make cmp reported no
differences and make install installed what appeared to be a working
compiler.  It builds hello world in C and C++ fine, and has built the
current development release of perl5 on -O2 cleanly (no compiling problems,
passed all perl regression tests).

However, there was a problem with failed regression tests on an interim
development release of perl 5.7 (ie a "development" development release)
which caused some sort of SEGV in the subroutine pp_rename caused by garbage
in memory where a pointer was expected - this was present on -O and -O2 but
went away on -g, so I don't know if it's a perl bug. [-g causes all
automatic variables to be zero initialised, doesn't it? So should I try
compiling with neither -g not -O to get no optimiser (and no chance of
optimiser bugs)?]

This gcc also builds working 2.2.16-rmk3 kernels. (not sure if previous
problems were misconfiguration D'oh on my part, or compiler, but that other
compiler is history now, so it doesn't matter)

> error.  Good luck with your bug.

Nicholas Clark

To UNSUBSCRIBE, email to debian-arm-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: