[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Video mode, X-cfb16, kernel make trouble, su fails, configure option

Philip Blundell wrote:

> >> 1. How do I set the startup/default fb mode?  Is it something like:
> >> boot cmd=video=cyber2000fb:vmode=1024x768
> >> That doesn't work.  I can use fbset just fine, but when X starts, it
> >> goes back to 640x480.  Also, I'd like to start with all of the VCs in
> >> 1024x768.
> >
> >I'm not sure.  I'm interested in that too.
> Looking at the source I don't think the cyber2000 driver supports options at
> the moment.  I think you have to recompile to change the default resolution.

Okay, I'll poke around in cyber2000fb.c and see what I can find.

> >> 1a. Is there a NeTTrom environment variable to set which passes options
> >> to the kernel?  Nothing given by printenv seems to match.
> >
> >I don't know.
> Isn't this what `cmdappend' does, or is that something else?  Probably best to
> ask on the netwinder newsgroups.

Will do.

Philip Blundell wrote:

> >Cool, thanks!  Now I can make, but the linker dies with the famous
> >
> >/usr/bin/ld: unrecognised emulation mode: armelf_linux
> Sigh.  That shouldn't happen -- the kernel ought to be smart enough to figure
> out what sort of linker you have.  Could you take a look at the NEW_LINKER
> gubbins at the top of arch/arm/Makefile, compare it to the output you get from
> your ld, and see if you can spot the problem?

I'm sorry.  I didn't make myself clear.  The problem is solved.  I read the
archives of this list, and one message indicated that the compiler uses linker
flags for binutils 2.9.4, but the latest package is 2.9.1, so I went and got 2.9.4
from ftp://ftp.debian.org/debian/projects/experimental (I think that was the
directory).  dpkg -i segfaulted on it the first two times, then magically worked
the third.

> ># dh_clean -k
> >dh_clean: No such file or directory
> Is `dh_clean' a script?  If so, check that the interpreter named in the first
> line of it exists.  If it's an executable, do the same for its dynamic linker.

Yes, it's a perl script, the interpreter is /usr/bin/perl, which works.

Adam C Powell IV wrote:

> # dh_clean
> # dh_clean -k
> dh_clean: No such file or directory

which means that it works fine with no options, but can't find itself with -k.  In
the /usr/bin/dh_clean perl script is the piece:

if (! $dh{K_FLAG}) {

but that's the only mention of the -k option.  I tried touch debian/files but that
didn't help.  I think maybe I should file a bug report for debhelper and see what

The rest of the build went fine, it generated binaries for ssh, ssh-agent, etc.

By the way, what's up with the missing kernel dirs in arch/arm?  I tried 2.2.12,
which died when it tried to make fastdep in arch/arm/drivers fastdep, and 2.3.16,
which died the same way for arch/arm/special.  Are these supposed to be generated??

Thank you again!


-Adam P.

Reply to: