[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Video mode, X-cfb16, kernel make trouble, su fails, configure option

Philip Blundell wrote:

> >3. Next, when attempting make config for the kernel (stock 2.2.12), I
> >get:
> >Makefile:240: *** target file `symlinks' has both : and :: entries.
> >Stop.
> >Never seen this before...  Any ideas?
> Here's a patch.  I'm not sure if this is the right thing to do but it appears
> to make the problem go away for me.

Cool, thanks!  Now I can make, but the linker dies with the famous

/usr/bin/ld: unrecognised emulation mode: armelf_linux

So I went to the archives, and found I should download binutils 2.9.4 from
project/experimental, but:

# dpkg -i binutils_2.
Segmentation fault


Okay, this is spooky.  Decided to try it a couple more times before sending
this, and on the third try, it worked!  So ignore the above.  (Anyone else
trying this, if it fails, try again!)

> >5. What file do I edit to tell configure scripts the host type?
> The config.guess script in the package you are trying to build.  The ones in
> /usr/share/automake are just there so that automake can copy them into new
> package directories.  In fact, you will probably find that the scripts there
> already know about all the right stuff and if you just copy them manually
> into the packages that have trouble everything will be peachy.
> But if only a couple of programs are affected it's often easier just to
> specify the system name (`arm-linux') on the command line.

Cool.  Had to edit debian/rules to stick in --host=arm-linux and then it
worked.  Thanks!

Time-saving tip to others building ssh (since I can't legally upload the package
:-) be sure to get socks4, the zilb devel package, and debhelper *before* you
start to build.  (Okay, so I'm a newbie. :-)  The configure script looks for
zlib, but not for zlib.h, is this a bug?  Am I allowed to report it?

Okay, here's a new one (this is after an almost-complete build using
debian/rules binary):

# debian/rules binary
dh_clean -k
dh_clean: No such file or directory
make: *** [binary-arch] Error 1
# which dh_clean
# vi debian/rules [replace dh_clean with /usr/bin/dh_clean]
# debian/rules binary
/usr/bin/dh_clean -k
dh_clean: No such file or directory
make: *** [binary-arch] Error 1
# ls -l `which dh_clean`
-rwxr-xr-x   1 root     root         1163 Aug 17 01:18 /usr/bin/dh_clean
# dh_clean
# dh_clean -k
dh_clean: No such file or directory
# grep dh_ `which dh_clean`

Any ideas?

[Jim, I missed your message because I downloaded it at home and now can't see it
at work.  I'll see it when the web list archive updates tonight.]

To all who are helping me out, a great big THANKS VERY MUCH!!  Our next meal
together is on me. :-)


-Adam P.

Reply to: