[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Video mode, X-cfb16, kernel make trouble, su fails, configure option

Adam C Powell IV <hazelsct@mit.edu> writes:

> Greetings,
> I'm afraid this is a bit of a kitchen sink message, can't find anything
> on any of these in the archive...
> 1. How do I set the startup/default fb mode?  Is it something like:
> boot cmd=video=cyber2000fb:vmode=1024x768
> That doesn't work.  I can use fbset just fine, but when X starts, it
> goes back to 640x480.  Also, I'd like to start with all of the VCs in
> 1024x768.

I'm not sure.  I'm interested in that too.
> 1a. Is there a NeTTrom environment variable to set which passes options
> to the kernel?  Nothing given by printenv seems to match.

I don't know.
> 2. Also, 16-bit X doesn't seem to work, fails on signal 11.  I guess
> this is because 8 bit was a priority, and got patched first? :-)  And
> 16-bit consoles are painfully slow!

Same here.

> 3. Next, when attempting make config for the kernel (stock 2.2.12), I
> get:
> Makefile:240: *** target file `symlinks' has both : and :: entries.
> Stop.
> Never seen this before...  Any ideas?

I've seen that before.  I think you get that if you haven't applied
the ARM patch to the kernel.

> 4. su root doesn't seem to work since upgrading to base-passwd
> and base-files 2.1.9.  I just get "su: incorrect password", but if I log
> out and back in as root, it's fine.  I'm using shadow passwords, but
> that shouldn't affect things, right?  It worked before the upgrade, with
> the base-files and base-passwd that came with the February image.

It seems to be happening here too.  I must have messed it up somehow.
I'll look at it again in a few days when I get some time.

> 5. What file do I edit to tell configure scripts the host type?  I'm
> trying to build ssh, and it gives:
> checking host system type... configure: error: can not guess host type;
> you must specify one
> I tried cp /usr/share/automake/config.guess . but I get the same error.
> (Searched the archive for words in the error message but didn't find
> anything :-(  )

You might want to try the config.guess and config.sub from libtool -
they are newer.  The kernel was recently changed so that uname -m now
returns 'armv4l' instead of 'arm'.

> Thanks very much for the help, for the X packages, and for the new
> base-passwd!

No problem.  I appreciate the bug reports.


 - Jim

Reply to: