[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#728937: apache2: broken in system upgrade due to mailgraph Recommends leading to tntnet installation

On 07.11.2013 16:06, Vincent Lefevre wrote:
>> In fact, it's not even a bug since you installed a leaf package
>> directly which is not meant to be used standalone.
> You're wrong. Users are not forced to install metapackages.
> I probably did "apt-get install apache2-mpm-itk" to make sure
> that this version of the server was installed (something that
> "apt-get install apache2" doesn't). It you think that apache2
> must have been installed too, then a "Depends: apache2" must
> have been added (and "Provides: apache2" should probably have
> been removed), or at least a "Recommends: apache2". Note that
> apache2-mpm-itk provided httpd, so that there were no reasons
> at all to install apache2 *explicitly*.

I did not say, that users are forced to install meta packages, but that
-mpm-* packages existed _only_ to let reverse dependencies depend on
them at Apache 2.2 time, as some modules require a particular MPM to run.

They are not meant to be installed standalone by users, and are now
fortunately going to disappear. In fact, all they do is to change the
link pointing to the MPM you are going to use. However, we cannot just
depend on the "apache2" package as you suggest, because some packages
use the binaries only, without wanting the full stack (configuration
files, handling, init scripts etc.) - e.g. look at gnome-user-share
which pulls apache2.2-bin.

If you look into the 2.2 packages you will notice, that neither of the
MPM packages _actually_ includes that MPM. They are all, always
installed by apache2.2-bin.

> No! Apache was already installed (with httpd provided by
> apache2-mpm-itk, so that this Recommends was satisfied). The
> problem is that apt pulled tntnet *in addition* to Apache.

Yes. But that's a problem of apt[itude], not of the packaging of Apache
as I said previously. We ensure that people having apache2-mpm-itk
installed get the appropriate package with the appropriate MPM providing
httpd in Apache 2.4 again.

If that makes apt think that there is no httpd installed for a transient
moment in time, well, there is not much we could do against other than
working around that limitation (or bug, if you may want to put it that
way) which we will do in future as you suggested.

> A Recommends on httpd | apache2 | apache2-mpm-worker |
> apache2-mpm-prefork | apache2-mpm-event | apache2-mpm-itk might
> have solved the problem, but I don't think it is up to mailgraph
> to know the internals of Apache packages. It is the job of Apache
> packages to make sure that the transition is OK.

Again, we do, unless you use packages in a way they are not meant to be

> "Everyone else is supposed to..." without a Depends or Recommends?
> That's insane!

Well. I gave you the reason why this is problematic. I suppose Gnome
users wouldn't like it if it would pull a web server listening on port
80 by default - don't you think?

I agree that this is a borderline case to insanity (and not even my
decision back then). but that's the way it is for Apache 2.2. Luckily we
do not need to worry anymore as in 2.4 MPMs are regular modules and do
not need a special treatment anymore.

with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: