[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apache module postinst/prerm scripts

On Sunday 21 November 2010, Massimo Manghi wrote:
> So, after a remove and subsequent install the package is disabled
> because  the symlinks from mods-enabled to mods-available are
> missing. I'm not sure I if I got it right, but it seems to me the
> checks on the arguments have to be changed, perhaps reenabling the
> module anyway under specific conditions (new-version ==
> old-version ?). Any suggestion?

True, that's a problem. But I don't see an elegant solution right now. 
On remove, you would have to remember if the package was enabled and 
on reinstall, you would then need to restore the original state.

It would probably make sense to create one script in the apache 
package to handle all this, which can then be used by all the module 
packages. But I definitely won't have time to implement that in the 
forseeable future.

Reply to: