[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#517126: apache2: PHP (5) support cannot be installed

Package: apache2.2-common
Version: 2.2.9-10+lenny2
Severity: important

Apache was upgraded during the move to Lenny. My previous installation had PHP enabled,
after the upgrade PHP still worked but MySQL access through PHP did not. The package
"php4-mysql" had been removed and could not be reinstalled. "php5-mysql" could be
installed, but did not work as "libapache-mod-php5" was not installed ---
"libapache-mod-php4" still was. I removed the latter and then:

$ sudo apt-get install libapache-mod-php5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libapache-mod-php5: Depends: apache-common (>= 1.3.34) but it is not installable
                      Depends: php5-common (= 5.2.0-10+lenny1) but 5.2.6.dfsg.1-1+lenny2 is to be installed
E: Broken packages

Now PHP support is totally gone and this cannot be remedied:

$ sudo apt-get install libapache-mod-php4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libapache-mod-php4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libapache-mod-php4 has no installation candidate


And I cannot even file a bug report against "libapache-mod-php5":

$ reportbug libapache-mod-php5
*** Welcome to reportbug.  Use ? for help at prompts. ***
Detected character set: us-ascii
Please change your locale if this is incorrect.

Using '"Axel K. Stammler" <axst@users.sourceforge.net>' as your from address.
Getting status for libapache-mod-php5...
A package named "libapache-mod-php5" does not appear to be installed; do you want to search for a similar-looking filename in an installed
package [Y|n|q|?]?

Sorry for filing against Apache 2 but what else can I do?

I think they should have waited a little longer until Lenny really has become stable:
Apache PHP does not work, Java has changed so much that my programs do not work anymore
and G Numeric rejects so of the most importnat formulas. (Sorry for the flame which does
not concern you but maybe you could tell me how to file a bug report against the upgrade
to Lenny.)

-- Package-specific info:
List of /etc/apache2/mods-enabled/*.load:
  000_auth_pgsql actions alias apreq asis auth_basic auth_digest
  auth_pam auth_plain auth_sys_group authn_alias authn_anon authn_dbd
  authn_dbm authn_default authn_file authnz_ldap authz_dbm
  authz_default authz_groupfile authz_host authz_owner authz_user
  autoindex cache cern_meta cgi cgid charset_lite dav dav_fs dav_lock
  dbd deflate dir disk_cache dump_io env expires ext_filter fastcgi
  file_cache filter headers ident imagemap include info ldap
  log_forensic mem_cache mime mime_magic negotiation perl proxy
  proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http rewrite
  setenvif speling ssl status suexec unique_id userdir usertrack
  version vhost_alias

-- System Information:
Debian Release: 5.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux (SMP w/1 CPU core; PREEMPT)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages apache2 depends on:
ii  apache2-mpm-prefork      2.2.9-10+lenny2 Apache HTTP Server - traditional n

apache2 recommends no packages.

apache2 suggests no packages.

Versions of packages apache2.2-common depends on:
ii  apache2-utils          2.2.9-10+lenny2   utility programs for webservers
ii  libapr1                1.2.12-5          The Apache Portable Runtime Librar
ii  libaprutil1            1.2.12+dfsg-8     The Apache Portable Runtime Utilit
ii  libc6                  2.7-18            GNU C Library: Shared libraries
ii  libmagic1              4.26-1            File type determination library us
ii  libssl0.9.8            0.9.8g-15         SSL shared libraries
ii  lsb-base               3.2-20            Linux Standard Base 3.2 init scrip
ii  mime-support           3.44-1            MIME files 'mime.types' & 'mailcap
ii  net-tools              1.60-22           The NET-3 networking toolkit
ii  perl                   5.10.0-19         Larry Wall's Practical Extraction 
ii  procps                 1:3.2.7-11        /proc file system utilities
ii  zlib1g                 1: compression library - runtime

-- debconf-show failed

Reply to: