[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#307567: apache2-common: Apache2 consumes 100% CPU after a few requests

On Wed, May 04, 2005 at 01:08:37AM +0200, Emmanuel Blot wrote:
> Package: apache2-common
> Version: 2.0.54-2
> Severity: grave
> Justification: renders package unusable
> It seems that the problem is related to LDAP authentication.
> The problem started showing up after the last 'aptitude upgrade' which
> has upgraded both the Apache2 server from 2.0.53 to 2.0.54, and libc6
> I tried to disable the ldap cache feature in the util_ldap Apache2
> module, with no success
> I also tried with the prefork and the worker variants: same issue.
> After a couple of requests to a URL which requires authentication, the Apache2 server starts eating up to 100%
> of CPU time. The problem does not show up with public access (ie no LDAP
> validation).
I'm not familiar with apache internals, nor LDAP, but I can try to
help begin diagnosis.

Could you provide a strace of the process when it is in that state?
(strace -p <pid>)?  Maybe also a strace of the process beginning
before it is in that state, and ending sometime after it has gone into
that state.

Maybe also a gdb backtrace?  (LD_LIBRARY_PATH=/usr/lib/debug gdb -p
<pid>); you should first install the package libc6-dbg, if possible.
If not, then don't set LD_LIBRARY_PATH.  It will at least tell us if
the stack is still sane, or if there has been memory corruption.

Depending on the result, I (or someone else) may request that you do
(or do not) compile some software with debugging enabled, which might
give the backtrace much more info.


Reply to: