[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#307567: apache2-common: Apache2 consumes 100% CPU after a few requests

Package: apache2-common
Version: 2.0.54-2
Severity: grave
Justification: renders package unusable

It seems that the problem is related to LDAP authentication.
The problem started showing up after the last 'aptitude upgrade' which
has upgraded both the Apache2 server from 2.0.53 to 2.0.54, and libc6

I tried to disable the ldap cache feature in the util_ldap Apache2
module, with no success

I also tried with the prefork and the worker variants: same issue.

After a couple of requests to a URL which requires authentication, the Apache2 server starts eating up to 100%
of CPU time. The problem does not show up with public access (ie no LDAP

The LDAP server works nicely with other clients, such as ldapsearch.

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.22-1-386
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages apache2-common depends on:
ii  apache2-utils               2.0.54-2     utility programs for webservers
ii  debconf               Debian configuration management sy
ii  debianutils                 2.8.4        Miscellaneous utilities specific t
ii  libc6                       2.3.2.ds1-21 GNU C Library: Shared libraries an
ii  libdb4.2                    4.2.52-18    Berkeley v4.2 Database Libraries [
ii  libexpat1                   1.95.8-3     XML parsing C library - runtime li
ii  libgcc1                     1:3.4.3-12   GCC support library
ii  libmagic1                   4.12-1       File type determination library us
ii  mime-support                3.28-1       MIME files 'mime.types' & 'mailcap
ii  net-tools                   1.60-10      The NET-3 networking toolkit
ii  openssl                     0.9.7e-3     Secure Socket Layer (SSL) binary a
ii  ssl-cert                    1.0-11       Simple debconf wrapper for openssl

-- no debconf information

Reply to: