[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#305302: apache2: segfaults when a websvn repository URL is accessed



On Tue, 19 Apr 2005 16:44, Adam Conrad wrote:
> And what versions of libapache2-mod-php4 and websvn do you have installed?
>  If you upgrade everything to unstable versions (if you upgrade apache2
> and happen to use suexec, watch out for bug #305242, which I'm uploading a
> fix for right now) does the problem magically go away?
I'm reluctant to play with the software on this too much, it's a server 
machine that I want to keep locked onto sarge as much as possible (and I'm 
still somewhat unfamiliar with Debian packaging procedures). However, the 
current versions of those packages are:
libapache2-mod-php4: 4:4.3.10-10
websvn: 1.61-13

> If not, can you run "apache2 -X" in gdb, make it segfault, and get us a
> backtrace?  That should help narrow down which package is at fault, and
> start giving me hints as to where it's broken.
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1079495520 (LWP 10557)]
0x406f2470 in mbfl_filt_conv_wchar_ascii ()
   from /usr/lib/apache2/modules/libphp4.so

... looks like it's a PHP issue.

-- 
Robin <robin@kallisti.net.nz>             JabberID: <eythian@jabber.org>

Hostes alienigeni me abduxerunt. Qui annus est?

PGP Key 0xA99CEB6D = 5957 6D23 8B16 EFAB FEF8  7175 14D3 6485 A99C EB6D

Attachment: pgpF9O3w1wwZ0.pgp
Description: PGP signature


Reply to: