[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#242499: libapache-mod-perl: same here

I've encountering a similar issue as the parent post but not I'm using
libapache-auth-cookie instead of bugtracker.
I've played around using different version of libapache-auth-cookie and
the problem is the same when querying a page (something like
* browser receives zero sized contents
* page is dumped in error.log without any other error message
(dumped pages are of various kind: dynamic php, css, jscript includes

What I also noted is that the problems occurs "more" frequently when I'm
also using mod-ssl (ssl encoded content gets dumped with full headers).
The same code worked without any flows when using libapache-mod-perl

You may be able to reproduce this by installing libapache-auth-cookie
and their "Sample" authenticator, configuring a protected directory in
apache according to their specification and putting a simple php script
(some <?php phpinfo() ?> ) into the protected dir.
I do have the fealing that the problems occurs when I request a page
with some get variables ( as said index.php?id=test) and it is more
frequent when using mod-ssl in conjunction. I also tried with various
browser but encountered the same problem.

Thanks for help,

S. Barbereau

Kernel:  2.6.10
Libc: 2.3.2.ds1-20
Perl: 5.8.4-5

Reply to: