[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#269757: apache-common: missing .info for mod_macro.so error during libapache-mod-php4 setup

Fabio Massimo Di Nitto wrote:

Setting up libapache-mod-php4 (4.3.8-9) ...
Error: mod_macro.so does not have a corresponding .info file.

apache-common does not ship mod_macro.so or the info file. mod_macro is
compiled in.

Please check /usr/lib/apache/1.3/ for any mod_macro.so and move them
somewhere. In any case that is a warning and not an error. It has been
converted as such, a long time ago.
Hi Fabio,

I suspected this was a built-in module, whatever the jargon is. This workaround you've mentioned seems to have solved it; I checked after a restart and the module still seems to be listed in apache's list. Time to see now if anything breaks. :)

I get the same error message when installing the latest apache 1.3.31-4
sarge package, *however* an error isn't reported by apache's setup. But as
per above libapache-mod-php4 does, so setup doesn't complete.

This is perhaps another bug related to php4 and i can't see why apache is
at fault. In anycase the php4 maintainer reads the list.

Perhaps. I guess now it's a case of trying to figure out who/what the heck installed the file in the first place? That raises a whole bunch of possibilities to me (though apache would be the prime -- though not the only -- suspect for me at this stage).

Again, thanks for your answer.


Jonathan Ah Kit - Lower Hutt - New Zealand
jonathan@ah-kit.dropbear.id.au - http://www.ah-kit.dropbear.id.au/
ahkitj@paradise.net.nz - ICQ#9747234 - http://www.electric.gen.nz/
Away message: Looking for adhesive tape, not Alibrandi.

Reply to: