[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apache-ssl "terminating unexpectedly"

Hi Mark,
	debian-apache mailing list in CC for historical reason and because
other might find useful help from tracking your problem down.

On Tue, 27 Apr 2004, Mark Lehrer wrote:

> I have been getting this error when I use Mozilla to connect to my SSL
> page for awhile, the apache-ssl log just says this:
> [Tue Apr 27 14:49:28 2004] [error] SSL_accept failed
> [Tue Apr 27 14:49:28 2004] [error] error:140760FC:SSL routines:SSL23_GET_CLIENT_
> HELLO:unknown protocol
> read in saferead: Connection reset by peer
> apache-ssl: gcachecommon.c:108: ReadThing: Assertion `nRead == sizeof usLength'
> failed.
> [Tue Apr 27 14:49:28 2004] [notice] child pid 28470 exit signal Aborted (6)
> Any idea what could be causing this?  I tried different browsers and
> tried re-generating the apache-ssl configuration, but I still get this
> error.

I would personally check 2 things here. First of all your certificate.
apache-ssl uses a (unfortunatly buggy) ssl-cert program to create its
certificates. Go into /etc/apache-ssl and remove apache.pem and the
symlink to it.
dpkg-reconfigure apache-ssl and when you are prompted for the certificate
questions be sure to answer to all of them.

If the problem still persists please check your configuration for SSLNoV2
and be sure that it is commented out.

Please also, when you are searching for help it is a very good idea that
you tell us which version of the packages that you are using.


<user> fajita: step one
<fajita> Whatever the problem, step one is always to look in the error log.
<user> fajita: step two
<fajita> When in danger or in doubt, step two is to scream and shout.

Reply to: