[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fwd: /bin/sh linked to dash? SOlVED, however..

Solved by

# mv /bin/sh /bin/sh_original

# ln -s /bin/bash /bin/sh


 ls -l
 sh -> /bin/bash

and mopac does its job. Hopefully, this should also allow the hundreds
of other codes inside the main code to work, if the same problem

However, I would like to have the opinion of "those who know" if this
is the correct way of doing and why with wheezy this change.


francesco pietra

---------- Forwarded message ----------
From: Francesco Pietra <chiendarret@gmail.com>
Date: Fri, Jul 1, 2011 at 7:48 PM
Subject: /bin/sh linked to dash?
To: amd64 Debian <debian-amd64@lists.debian.org>

I wonder whether amd64 wheezy links /bin/sh to dash instead of bash.

I am getting error "Bad fd number, can't run mopac.h" in a mopac.sh
calculation (mopac compiled fortran, in fact a FOR005 file is
generated, and not deleted by mopac probably because it was running

I am asking that (and thus if a symlink is needed using bash, as in my
case) because with the same code (and same calculation) I had no such
error with amd64 lenny. I have just copied the whole
molecular-mechanics compiled code (which includes mopac among hundreds
of other codes) from a lenny machine to a wheezy machine. The reason
of the copy is that the molecular-mechanics code can't be compiled
with recent gcc/fortran (its loose fortran is not allowed by recent
compilers) while the wheezy cuda machine is far faster than the old
cpu machine.

francesco pietra

Reply to: