[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ATI proprietary drivers installation failures


I've been searching for this issue on the archives of the mailing and could
only found old (2006) topics. So, I decided to post here, hoping someone
will be able to help me.

Here is the problem:

I can't install official ATI drivers for my graphic card when using 64 bits
kernels (tested on lenny and squeeze).
At the end, X programs (as for aticonfig) do not start, complaining about they
can't find some libraries (first is libXrandr). In fact, these programs expect
64 bits libraries, which are not providen with Debian.
Of course, making a simple link from these libraries into lib64 directory
doesn't help since (the programs complain then about these libraries are 
ELF32 and not ELF64).

I also tried fglrx packages providen in the non-free section of Debian, but with
no more success.

I tried to send a topic on the official ATI forum but noone at all answered me.
I also tried on the OpenGL forum, and there someone said me that he encountered
no problems at all using Ubuntu.

So for now, I'm still stuck with 32 bits.

my system: 
packard bell easynote LJ61 (laptop)
AMD Athlon 64 X2
ATI Mobility Radeon 4570
Debian Squeeze (and until yesterday night: Debian Lenny).

Thanks in advance for hints or solutions.



Reply to: