[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

blank Xorg on Etch

Greetings earthlings.
There doesn't seem to be an X-related list, or i couldn't find it.

I had issues booting the Etch netinst for AMD64. I tried Knoppix 5.0.1
- worked like a charm, X and all, except for sound. Tried live Ubuntu
5.04 for Inter x86, complained about X. Tried Ubuntu 5.04 for AMD64,
complained about acpi; then about X. LFS 6.2.3 booted fine (has no X).

So after booting the Debian installer with noacpi i finally installed
Etch through netinst. Until then it would freeze after "io scheduler
cfq registered" and the only suggestion i got from the lists was to
burn another disc... Anynway, now i'm complaining about X. The sound i
dealt with,  added "options snd-hda-intel position_fix=1 model=3stack"
to /etc/modprobe.d/alsa-base

Which is better, ALSA or OSS?

The system boots fine, actually it flies. As usual a Debian "basic"
install always adds unnecessary things - why the hell is there a
Bittorrent tracker?! Once X starts the screen blanks, beeps once, and
the monitor LED keeps blinking. It responds to Ctrl+Alt+Backspace
(does the same again) and i can switch to console. This is ps -A from
the first graphics-related PID:
 3018 ?        00:00:00 gdm
 3024 ?        00:00:00 gdm
 3029 tty7     00:00:00 Xorg
 3030 ?        00:00:00 rpc.statd
 3031 ?        00:00:00 dhclient
 3062 ?        00:00:00 atd
 3069 ?        00:00:00 cron
 3104 tty1     00:00:00 login
 3105 tty8     00:00:00 getty
 3114 ?        00:00:00 gdmgreeter
How come there are two gdm? Eventually i'll switch to xdm and xfce4.

The motherboard is an ASUS M2NPV-VM. Details can be found here:
- AMD Athlon 64 3500+
- graphics card is a nVidia GeForce 6150, i think
- 2GB of RAM (DDR2 667 DualChannel, 128bit)
- phoenix Award BIOS v6.00PG

X is running the nv driver. I tried installing the nvidia driver from
their site (file NVIDIA-Linux-x86_64-100.14.19-pkg2.run) but it
complains about libc - mine's 6 and i assume it's current. Gcc is ver
4.1.2 20061115 (prerelease) (Debian 4.1.1-21). Once i've comented out
loading of dri and glx modules, i find no errors in X's log. Oddly
enough issuing "gcc -v > file" or similar for xorg won't redirect but
that's irrelevant for now. I don't really care about 3D - if i can get
it then all the better. If i can get X to work without closed drivers,
even sweeter.

Here are the usual suspects:


uname -a gives:
Linux deb64 2.6.18-5-amd64 #1 SMP Thu May 31 23:51:05 UTC 2007 x86_64 GNU/Linux

I tried dpkg-reconfigure xserver-xorg but found nothing noteworthy. It
detected the same resolutions as XP Pro x64 currently does: 800x600,
960x600, 1024x768 at 32bit. The monitor is a Samtron 55E. My other box
is and old Pentium 2 i'm LAMPing up with Debian Etch for i386 and X
works (almost) fine. I had to comment out dri and glx as well, the
window manager won't start up properly but it's working. Here's its
I use the same monitor for both machines, although now i managed to
remote an X session to the old box.

After running dpkg-reconfigure i got these errors in Xorg.0.log
(EE) Unable to find a valid framebuffer device
(EE) NV(0): Failed to open framebuffer device, consult warnings and/or
errors above for possible reasons
(EE) Screen(s) found, but none have a usable configuration.
Full log:
Resulting xconf:

...so i reverted to the old config files and got back where i started.
When i had Sarge the only issue i had with X under Debian was changing
the /dev for the mouse and everything worked fine (on that old box,
still XFree86), but now...

Hopefully this is enough information. And, according to Murphy, it's
probably a very easy and silly thing to solve.

Thanks in advance.

Fica bem, porta-te mal.
Be well, misbehave.

Reply to: