[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB devices not being seen

On Saturday 18 November 2006 19:35, Eduardo M KALINOWSKI wrote:
> Hi,
>     I'm facing a strange problem: sometimes USB devices are not beeing
> seen by my linux (2.6.17-2-amd64) system. And when I mean not beeing
> seen, I mean that lsusb shows something like this even when the device
> is plugged in:
> Bus 004 Device 001: ID 0000:0000
> Bus 003 Device 001: ID 0000:0000
> Bus 002 Device 001: ID 0000:0000
> Bus 001 Device 001: ID 0000:0000
> Which is the same output as when there is no USB device. Also, no
> messages are printed in the console or shown by dmesg.
>     This has happened with a mp3 player and two cell phones (a Motorola
> C650 and a Sony-Ericsson K750i), so it's not a problem with the device.
> What's strange is that the connection is detected by the devices: the
> mp3 player, for example, turns on and displays the usual screen shown
> when it's connected to the computer. I've even tried plugging it without
> the battery and it still turns on. Also, the K750i, when plugged,
> supposedly starts charging (which is the expected behaviour). However,
> even though it appears to be charging, when I left it plugged for a long
> time I noticed it did not appear to have charged anything.
>     Plugging the device in another usb port does make it work, at least
> sometimes. But it is not a problem with one specific usb port, sometimes
> a port work, sometimes it does not.

I noticed with my own k750i that it sometimes didn't show up when doing 
fdisk -l.  However, I tried fdisk /dev/sdb  (I have one SATA drive at sda)  
and when I typed p, it shew the correct partition table; when I typed q, I 
was able to mount /dev/sdb1 normally.

I guess this is something to do with udev or hal or something weird in the way 
2.6 kernels deal with hardware.

delta echo bravo six four at earthshod dot co dot uk

Reply to: