[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 6GB RAM on a Tyan S2875 Tiger K8W - 500 MB missing

On Fri, Jul 07, 2006 at 10:25:26AM +0200, Raimund Jacob wrote:
> i upgraded the RAM of my workstation yesterday and have some problems
> understanding what i'm seeing.
> here is what i did: started with 4 GB of RAM, made up from 4x1GB
> registered non-ECC modules. all working well. ripped apart a new server
> that came with 2x2GB registered ECC modules (also worked well, so
> hardware defect is out of the question). the plan was to put those 2x2
> in my workstation, leaving 2x1 in place.
> that's what i did and i saw only 4 GB, but that was kinda logical
> because the 2x1 are non-ECC and i had to tell the BIOS about that. after
> disabling ECC alltogether the machines boots with the BIOS reporting
> 57xx MB of memory. my kernel says:
> Memory: 5746100k/7438336k available (2638k kernel code, 118684k
> reserved, 996k data, 196k init)
> here is what i dont get: 6x1024MB are 6144MB but BIOS and kernel report
> only 5611MB - so where are my 533MB ?!
> i first though this might be an due to the way i plugged the modules
> into the DIMM slots and tried some other patterns. it turns out that the
> ECC modules alone only work when put into DIMM1/DIMM2 or DIMM1/DIMM3 -
> in combination  with the non-ECC modules it only works with the 2x2 in
> DIMM1/DIMM2 and the 2x1 in DIMM3/DIMM4. again, ECC is disabled in the
> BIOS completely - otherwise it wouldnt use the non-ECC modules at all.
> so i'm thinking if this is some kind of artefact of some "memory hole"
> i'm not aware of.
> also, the manual of the board (Tyan Tiger K8W S2875) contains a little
> chart that supposedly shows how 64bit (non-interleaved) and 128bit
> (interleaved) memory configurations work. but with all i know about
> computers i cannot interpret nor understand it:)
> question is: where is my memory ?! it's too much to be a miscalculation
> of some form (like the HDD manufacturers do it :) could anyone make
> sense of my BIOS-provided physical RAM map if i posted it? what am i
> missing?

There is usually a memory hole for BIOS and PCI access, at 3.5 to 4GB.
So unless your bios supports memory holes/memory remapping (most do with
the right bios setting), then you loose that ram.  Check your bios for
some settings related to memory holes or something similar.

According to what I remember, a setting for 'memory hole' in the bios
should be set to 'software' on tyan boards (assuming your bios is new
enough to have the option).  Back when I saw this, they were talking
about having to use beta bios releases to get the option, but that was a
while ago (as in last fall).

Len Sorensen

Reply to: