[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Playing an encrypted/comercial DVD - libdvdcss

I have copied this message from the Ubuntu list since this is an AMD64 issue and would like to ask if anyone on here have been able to get DVDs to play and if there were any issues how you were able to over come them.

I have been trying to get libdvdcss to compile on my AMD64 3000+ box but keep on getting errors output to the terminal.

Chanchao wrote:
> Stephen Liu wrote:
>> I'm running Ubuntu-desktop-6.0.6 64 bits Live CD with only Totem
>> installed.  Any chance for me playing CD/DVD movie?  I have a CDRom and
>> DVD writer installed on the box.  The Live CD is now on CDRom.  TIA
> No problem.  There's some legal & licensing reasons why it doesn't just
> work out of the box, but not problem to enable it.
> Same is true for MP3 music, MPEG video in general, WMV video, etc, etc.
> See: https://help.ubuntu.com/community/RestrictedFormats

I have a new AMD64 and have not been able to play commercial DVDs.  I see the very beginning video and when the encrypted part starts up.. xine quites on me.  I took the advise and when to the link up above and followed all the instructions.  However when it got to this section I am dead in the water.

      Installing libdvdcss2

            Applies to the AMD64 architecture only:
                  The install-css.sh script will compile the libdvdcss2 library for you instead of downloading a prebuilt binary. Make sure you install the debhelper, build-essential and fakeroot packages first. Then issue the command

                  sudo /usr/share/doc/libdvdread3/examples/install-css.sh

Since I have AMD64 I ran the above script with all the proper packages installed above I get these errors:


make[4]: Entering directory `/tmp/dvd/libdvdcss-1.2.5/src/dvdcss'
make[4]: Nothing to be done for `all'.
make[4]: Leaving directory `/tmp/dvd/libdvdcss-1.2.5/src/dvdcss'
make[4]: Entering directory `/tmp/dvd/libdvdcss-1.2.5/src'
if /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I..     -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DDVDCSS_DIST -Wsign-compare -Wall -g -O2 -MT libdvdcss.lo -MD -MP -MF ".deps/libdvdcss.Tpo" \
          -c -o libdvdcss.lo `test -f 'libdvdcss.c' || echo './'`libdvdcss.c; \
        then mv ".deps/libdvdcss.Tpo" ".deps/libdvdcss.Plo"; \
        else rm -f ".deps/libdvdcss.Tpo"; exit 1; \
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I.. -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DDVDCSS_DIST -Wsign-compare -Wall -g -O2 -MT libdvdcss.lo -MD -MP -MF .deps/libdvdcss.Tpo -c libdvdcss.c  -fPIC -DPIC -o .libs/libdvdcss.lo
libdvdcss.c: In function 'dvdcss_open':
libdvdcss.c:367: warning: pointer targets in passing argument 1 of 'strlen' differ in signedness
libdvdcss.c:381: warning: pointer targets in passing argument 1 of 'sprintf' differ in signedness
libdvdcss.c:394: error: 'EEXIST' undeclared (first use in this function)
libdvdcss.c:394: error: (Each undeclared identifier is reported only once
libdvdcss.c:394: error: for each function it appears in.)
libdvdcss.c:418: warning: pointer targets in passing argument 1 of 'sprintf' differ in signedness
libdvdcss.c:419: warning: pointer targets in passing argument 2 of '_dvdcss_debug' differ in signedness
make[4]: *** [libdvdcss.lo] Error 1
make[4]: Leaving directory `/tmp/dvd/libdvdcss-1.2.5/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/dvd/libdvdcss-1.2.5/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/dvd/libdvdcss-1.2.5'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/dvd/libdvdcss-1.2.5'
make: *** [build-stamp] Error 2

I have even ran ./configure in the /tmp/dvd/libdvdcss-1.2.5/src/dvdcss directory and still when I ran make I got the same errors.

looking at just the ./configure output when I cd into /tmp/dvd/libdvdcss-1.2.5 I  get this:


checking whether -lc should be explicitly linked in... no
creating libtool
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for size_t... yes
checking for unistd.h... (cached) yes
checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking sys/ioctl.h usability... yes
checking sys/ioctl.h presence... yes
checking for sys/ioctl.h... yes
checking sys/cdio.h usability... no
checking sys/cdio.h presence... no
checking for sys/cdio.h... no
checking sys/dvdio.h usability... no
checking sys/dvdio.h presence... no
checking for sys/dvdio.h... no
checking linux/cdrom.h usability... yes
checking linux/cdrom.h presence... yes
checking for linux/cdrom.h... yes
checking dvd.h usability... no
checking dvd.h presence... no
checking for dvd.h... no
checking /sys/dev/scsi/scsi_ioctl.h usability... no
checking /sys/dev/scsi/scsi_ioctl.h presence... no
checking for /sys/dev/scsi/scsi_ioctl.h... no
checking sys/scsi/scsi_types.h usability... no
checking sys/scsi/scsi_types.h presence... no
checking for sys/scsi/scsi_types.h... no
checking sys/scsi.h usability... no
checking sys/scsi.h presence... no
checking for sys/scsi.h... no
checking IOKit/storage/IODVDMediaBSDClient.h usability... no
checking IOKit/storage/IODVDMediaBSDClient.h presence... no
checking for IOKit/storage/IODVDMediaBSDClient.h... no

A bunch of 'no's and when looking into my /sys I clearly do not have a /sys/dev directory.  My /sys looks like this:

block/  bus/  class/  devices/  firmware/  fs/  kernel/  module/  power/

and even if I do 'make' I get the same errors as well


Reply to: