[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED: Software-RAID1 on sarge (AMD64)

On Mon, May 29, 2006 at 04:32:17AM +0200, Goswin von Brederlow wrote:

> If raid is buildin into the kernel and all the disk drivers for the
> raid too then the type 0xFD causes the kernel to already detect and
> start the raid. So you need no initrd and no mdadm to boot. So in your
> case you DO need that. (PS: I prefer non initrd boot too and have the
> same).

Yeah. I tried initramfs a couple of weeks ago using etch, but

- initramfs-tools assembled the arrays in the wrong order and therefore
  tried to mount the swap device as "/" - eeeek...
- yaird failed to assemble the root array when the components of the
  array got different names than when the initramfs was created (e.g.
  due to moving the disks to a different controller). Btw. for the same
  reason yaird is also horribly broken for the non-RAID case as well.

So I decided that initramfs support in etch is definitely not ready for
production use and went back to the good old "no init(rd|ramfs)" setup.


     MTA SZTAKI Computer and Automation Research Institute
                Hungarian Academy of Sciences

Reply to: