[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SATA, RAID and GRUB



On (12/05/06 13:24), Erik Brucken wrote:
> On Friday 12 May 2006 13:05, Valero Pascual wrote:
> > Hello!!
> >
> > I have a computer with amd64 and I am trying to install the sarge for amd64
> > with a minimum CD for net, I lower the image ISO:
> > should-31r0a-amd64-netinst. Antecedentes: I must say that the computer has
> > two disks SATA 160Gb configured as RAID 0 from the BIOS CONFGURATION RAID,
> > therefore, one should only see as a disk of about 320 Gb; previously I had
> > installed Windows, I made a partition of the 160Gb of the 320 that you/they
> > saw each other and I proceeded to formatear this partition and to install
> > Windows and other programs for Windows.  I began the installation of Sarge
> > for amd64 but the moment arrived to carry out the partitions of the root /
> > and I exchange or swap and to give format. Which it would be my surprise
> > when observing that linux not sees a hard disk of one 320 Gb but rhater 2
> > of 160 Gb as if is 2 normal IDE. As the partition of Windows it was of
> > 160Gb I didn't give him importance (this can be a hint) and I defined the
> > partitions ext3 and swap for the second hard disk, then I gave format to
> > the disk and seemingly the he/she made it without problems. To install
> > Grup: I decide to make it in the root / of LINUX (another since problem
> > doesn't allow me) but it is not possible because the denominations for the
> > disks SATA should be /dev/sdb1... /dev/sdb2 I attempt it but one is not
> > able to, therefore, I decide to install GRUP in the Master Boot Record, and
> > it is made correctly. It finishes the installation and I restart giving me
> > grup the error 21.
> >
> > Can somebody help me saying me that I make bad?
> >
> > Thank you.
> >
> > Diofanto.
> 
> I had the same same error after upgrading grub  some weeks ago. I am running 
> softraid 1 with two SATA Disks. All I was trying failed. So at the end I was 
> installing a base system on one of the two harddiscs root partition and 
> reinstalling grub. After turning on the raid everything worked again fine. 
> You might want to use a livecd as knoppix to install grub manually.

You may find these links useful:

# http://rootraiddoc.alioth.debian.org/
# http://juerd.nl/site.plp/debianraid
# http://xtronics.com/reference/SATA-RAID-Debian.htm

Regards

Clive

-- 
www.clivemenzies.co.uk ...
...strategies for business




Reply to: