[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Dropping to a shell

You can lsmod in the shell and find out whether or not the driver for
your SATA or SCSI card is loaded. If not, then you have to boot again
with your netinst CD and mount the root partition. Modify the
/etc/modules to include the driver, and re-make the initramfs.

Bhaskar S. Manda
Financial Engineer
Cooperfund, Inc.
611 Enterprise Dr.  Oak Brook, IL 60523-8811
(630) 573-8700  (630) 573-0652 (Fax)

> -----Original Message-----
> From: William Humphrey [mailto:cwhumphrey@calgb.duhs.duke.edu] 
> Sent: Thursday, March 16, 2006 1:05 PM
> To: Glenn English
> Cc: debian-x86-64@lists.debian.org
> Subject: RE: Dropping to a shell
> Thanks for the reply Glenn!
> I just tried your suggestion and it still does the same 
> thing. I also forgot to mention that I am using Quad Xeon's 
> 3.33ghz 64-bit. I did an
> ls- l on my partition /dev/cciss/c0d0p1 and it finds it, but 
> ctrl-d does get me out of the shell, it just continues to say 
> "tty job control turned off". Do you maybe have any other suggestions?
> -----Original Message-----
> From: Glenn English [mailto:ghe@slsware.com]
> Sent: Thursday, March 16, 2006 12:32 PM
> To: debian-amd64@lists.debian.org
> Subject: Re: Dropping to a shell
> On Wednesday 15 March 2006 15:15, William Humphrey wrote:
> > I am using the latest official testing version of  debian (kernel
> > 2.6.15) on a DL580 G3 with Quad Procs. I used the netinst 
> image. Once
> I
> > installed the program, I have the problem to where is keep 
> dropping to
> a
> > shell and will not boot. It say that it cannot find my hard drive 
> > partition which is /dev/cciss/c0d01. And on top of that, it 
> does not 
> > create an /etc/fstab for me to mount it. I have tried 
> creating a fstab 
> > myself, but once I reboot, it goes away. Has anyone had 
> this problem?
> If
> > so please help!
> Waiting 20 seconds and ctl-d'ing out of the shell works here.
> When mine does that "drop into a shell" trick, I just let it 
> sit for 10 or 15 seconds. The boot process prints on the 
> screen that it's created the relevant drive in /dev. And a 
> couple seconds after that, 'ls /dev/sd*' shows the 
> partitions. And ctl-d climbs out of the shell, and the boot 
> process finishes.
> What you describe is happening here on 2 machines: a dual 
> Opteron Sun running smp etch in 32 bit mode and a single P4 
> homebrew running sid. Both of them have a SCSI boot drive and 
> a SATA to store big stuff on. (The servers running sarge are fine.)
> The 2.6.15 kernel and/or the current udev and/or something 
> else I don't know about are/is bent pretty badly. SATA drives 
> are not SCSI drives. If the developers want to run them 
> through the SCSI driver, that's fine. But they could at least 
> call them sdA... so things wouldn't get confused. 
> And whoever's doing that reordering should be put up against the wall.
> Or at
> least the installer should be told about the reordering algorithm.
> --
> Glenn English
> ghe@slsware.com
> GPG ID: D0D7FF20
> -- 
> To UNSUBSCRIBE, email to debian-amd64-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org

Reply to: