[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HOWTO Installing a Debian IA32 chroot system

garys@opusnet.com (Gary W. Swearingen) writes:

> I'd like some help deciphering the debian-amd64-howto.html HOWTO.
> Specifically, the "Installing a Debian IA32 chroot system" section.
> (I'm trying to get "realplayer" running in a month-old 64-bit
> "etch". I don't recall why I chose "etch" instead of "sid" or "sarge";
> maybe someone can remind me. :)
> The HOWTO has one do "chroot /var/chroot/sid-ia32", and then starts
> talking about "/whatever", without saying whether that's the base "/"
> or the chroot's "/".
> Reading between the lines, I'm guessing it means the base
> /etc/ld.so.conf,  so I changed that.

If you want to run without chroot command then no conffile inside the
chroot will have any effect. Logicaly it can only mean outside the

> But now I don't understand this at all:
>     You also need a link to your 32bit linker in the /lib path. Change
>     in to directory /lib and create a link to the 32bit linker library
>     of your chroot: (The name of the 64bit linker is
>     ld-linux-x86-64.so.2)

Please ignore that and instead just "apt-get install libc6-i386". That
package will provide the linker and a 32bit libc that will be current.

> I'm again guessing it wants the link in the base "/lib", but what
> should the link be named?  I surely don't want to replace the 64-bit
> linker with a link to the 32-bit linker, do I?  I need more steps in
> my cookbook or a better explanation of what's going on.
> It seems that the goal here is to be able to run a 32-bit app (I'm
> trying to run the Real Video player) without having to do a chroot.
> Correct?
> I tried to install RealPlayer10GOLD.rpm in the chroot, and it seemed
> to install OK, but when I run it (RealPlayer10GOLD.bin, within the
> chroot) I get this msg:
>    home/jojo/bin/RealPlayer10GOLD.bin: error while loading shared
>    libraries: libstdc++.so.5: cannot open shared object file: No such
>    file or directory
> Within the chroot, "ls -d /usr/lib/libstd*" gives:
> lrwxrwxrwx  1 root root     18 Feb 12 03:31 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.7
> -rw-r--r--  1 root root 882324 Jan 29 03:50 /usr/lib/libstdc++.so.6.0.7
> So, it seems I have two question, one about configuring "ldconfig" and
> the other about how to install/configure a libstd++.so.5 for
> "realplayer".

You have to get that library. The package is even names libstdc++5.

> (BTW, I'm returning to Linux after 6 years of FreeBSD (don't ask), for
> which I don't recall a single library version problem, and almost the
> first thing I do after the OS install is be reminded of many old
> memories of Linux library problems.  I never did learn what they did
> differently.  I sure hope the problematic Linux way has some side
> benefit I'm not aware of.)

That is what you get for not using debs. rpms don't have Debians
dependencies. (I know, it can't be helped. But it isn't our fault if
it breaks.)

> Thanks.


Reply to: