[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Custom kernel for Debian-installer howto?

Hash: SHA1

On Mon, 6 Mar 2006 11:57:24 -0500
lsorense@csclub.uwaterloo.ca (Lennart Sorensen) wrote:

> On Sat, Mar 04, 2006 at 07:34:15AM -0600, Jacob S wrote:
> > I'm trying to install Debian Sarge on an AMD Athlon64 3200+. The
> > problem is the installer doesn't recognize my Uli 1689 SATA chipset.
> > However, this chipset appears to be supported in 2.6.12 and later
> > kernels with the sata_uli module. 
> > 
> > I have found some discussions about how to rebuild the
> > debian-installer with a custom kernel, but I am not sure if it will
> > work in my case. Being the new machine is my only AMD64 machine so
> > far, I will have to build the debian-installer and kernel on a
> > 32bit AMD running Sid, or my AMD64 machine running 32bit Knoppix.
> > Is there anything special I would need to do to get it to build
> > right?
> > 
> > Any other tips or suggestions on how to get the AMD64 port of Debian
> > installed on this machine?
> http://www.tinyplanet.ca/~lsorense/amd64 has a sarge install cd with a
> 2.6.12 kernel.  It has worked for other people with that chipset.
> You may have to load the uli sata driver from console2 manually to
> make it detect the disk.

Thanks. This was exactly what I did the other day when I finally got
Sarge installed. I did have to manually modprobe sata_uli from console
2 as you mention, but that was no big deal. I finally found the
installer by doing a google for "debian-install uli 5289" instead of
"debian-installer uli m1689". 

Also, for those that might google this in the future, my IDE solution
failed. As with the only other SATA mobo I've played with, this mobo
does not like to boot off any kind of hdd when there is both a SATA hdd
and IDE hdd connected. It will however boot off a hdd when there is an
IDE cdrom attached. Yet the BIOS reports the two IDE channels as 0 & 1,
and the SATA as being channel 2. Whatever. The amd64 installer linked
above worked perfectly. 

Thanks again,
Version: GnuPG v1.4.2 (GNU/Linux)


Reply to: