[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: trouble with hotplug on sid

On Tue, Feb 14, 2006 at 02:59:11PM +0000, A J Stiles wrote:
> I am running Sid on AMD64 and have been holding off from doing an apt-get 
> upgrade for awhile, as there seemed to be some problems with KDE and its 
> dependencies and as a consequence, APT wanted to remove important packages 
> right, left and centre.  I tried today and was pleased to see that it was not 
> going to remove any packages as before; however, I get an error with hotplug, 
> as follows:
> adam3:~# apt-get upgrade
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following packages have been kept back:
>   adduser akregator amor .....  [stuff omitted] .....  xutils yelp
> The following packages will be upgraded:
>   hotplug
> 1 upgraded, 0 newly installed, 0 to remove and 402 not upgraded.
> Need to get 0B/66.7kB of archives.
> After unpacking 8192B of additional disk space will be used.
> Do you want to continue? [Y/n] y
> Preconfiguring packages ...
> (Reading database ... 143638 files and directories currently installed.)
> Preparing to replace hotplug 0.0.20040329-16 
> (using .../hotplug_0.0.20040329-25_all.deb) ...
> mv: target `/etc/modprobe.d/isapnp-backup/' is not a directory: No such file 
> or directory
> dpkg: error processing /var/cache/apt/archives/hotplug_0.0.20040329-25_all.deb 
> (--unpack):
>  subprocess pre-installation script returned error exit status 1
> Errors were encountered while processing:
>  /var/cache/apt/archives/hotplug_0.0.20040329-25_all.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> I tried `apt-get install -f` which sometimes fixes things.  This time around 
> it seemed to finish the aborted installation; but when I try apt-get upgrade 
> again, I get the same error with hotplug.
> Do I just need to make the missing directory
> /etc/modprobe.d/isapnp-backup/
> or is there more to it than that?

My sid system told me to purge hotplug because udev replaces it.  I
don't know what state hotplug is actually in any more.  It is certainly
being deprecated as far as I understand.

Len Sorensen

Reply to: